Mailinglist Archive: opensuse-updates (67 mails)

< Previous Next >
openSUSE-SU-2011:0480-1 (moderate): kdelibs4: fixing XSS vulnerability in KHTML error pages (CVE-2011-1168)
openSUSE Security Update: kdelibs4: fixing XSS vulnerability in KHTML error
pages (CVE-2011-1168)
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0480-1
Rating: moderate
References: #686652
Cross-References: CVE-2011-1168
Affected Products:
openSUSE 11.4
openSUSE 11.3
openSUSE 11.2
______________________________________________________________________________

An update that fixes one vulnerability is now available. It
includes one version update.

Description:

A XSS vulnerability in the way KHTML handles error pages
has been fixed. CVE-2011-1168 has been assigned to this
issue.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch kdelibs4-4406

- openSUSE 11.3:

zypper in -t patch kdelibs4-4406

- openSUSE 11.2:

zypper in -t patch kdelibs4-4406

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

kdelibs4-4.6.0-6.15.1
kdelibs4-branding-upstream-4.6.0-6.15.1
kdelibs4-core-4.6.0-6.15.1
kdelibs4-doc-4.6.0-6.15.1
libkde4-4.6.0-6.15.1
libkde4-devel-4.6.0-6.15.1
libkdecore4-4.6.0-6.15.1
libkdecore4-devel-4.6.0-6.15.1
libksuseinstall-devel-4.6.0-6.15.1
libksuseinstall1-4.6.0-6.15.1

- openSUSE 11.4 (x86_64):

libkde4-32bit-4.6.0-6.15.1
libkdecore4-32bit-4.6.0-6.15.1
libksuseinstall1-32bit-4.6.0-6.15.1

- openSUSE 11.3 (i586 x86_64):

kdelibs4-4.4.4-3.6.1
kdelibs4-branding-upstream-4.4.4-3.6.1
kdelibs4-core-4.4.4-3.6.1
kdelibs4-doc-4.4.4-3.6.1
libkde4-4.4.4-3.6.1
libkde4-devel-4.4.4-3.6.1
libkdecore4-4.4.4-3.6.1
libkdecore4-devel-4.4.4-3.6.1
libksuseinstall-devel-4.4.4-3.6.1
libksuseinstall1-4.4.4-3.6.1

- openSUSE 11.3 (x86_64):

libkde4-32bit-4.4.4-3.6.1
libkdecore4-32bit-4.4.4-3.6.1
libksuseinstall1-32bit-4.4.4-3.6.1

- openSUSE 11.2 (i586 x86_64) [New Version: 4.3.5]:

kdelibs4-4.3.5-0.5.1
kdelibs4-branding-upstream-4.3.5-0.5.1
kdelibs4-core-4.3.5-0.5.1
kdelibs4-doc-4.3.5-0.5.1
libkde4-4.3.5-0.5.1
libkde4-devel-4.3.5-0.5.1
libkdecore4-4.3.5-0.5.1
libkdecore4-devel-4.3.5-0.5.1

- openSUSE 11.2 (x86_64) [New Version: 4.3.5]:

libkde4-32bit-4.3.5-0.5.1
libkdecore4-32bit-4.3.5-0.5.1


References:

http://support.novell.com/security/cve/CVE-2011-1168.html
https://bugzilla.novell.com/686652


< Previous Next >
This Thread
  • No further messages