Mailinglist Archive: opensuse-updates (19 mails)

< Previous Next >
openSUSE-RU-2011:0108-1 (low): samba: Collective Fixes update
openSUSE Recommended Update: samba: Collective Fixes update
______________________________________________________________________________

Announcement ID: openSUSE-RU-2011:0108-1
Rating: low
References: #602418 #606304 #625936 #637755 #640870 #654719
#656112 #661842
Affected Products:
openSUSE 11.3
______________________________________________________________________________

An update that has 8 recommended fixes can now be installed.

Description:

This collective update for samba provides the following
fixes:

- Remove pcap_cache_loaded asserts from (re)load_printers.
pcap_cache_loaded() returns false if the pcap cache
contains no printer entries. correct call ordering is
already enforced. (bso#7836); (bnc#625936).
- Fix error paths in cups_async_callback(), an empty cups
printer list should not be treated as an error;
(bnc#661842).
- Abide by printcap cache time, reload parent smbd pcap
cache on expiry; (bso#7836); (bnc#625936).
- Fix race in cups async printer services reload;
(bso#7836); (bnc#625936).
- Fix Dolphin SMB share IO with SMB signing enabled;
(bso#7791); (bnc#656112).
- Reduce unnecessary ldap round trips and eliminate invalid
DN messages; (bnc#654719).
- Fix smbd crash with CUPS printers and no [printers] share
defined; (bso#7297); (bnc#637755).
- Fix printing from 64-bit windows clients; (bso#6888);
(bnc#640870).
- Use cached ntlm password in libsmbclient. Prevent
lockouts when kerberos tickets are lost; (bnc#602418);
(bnc#606304).


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch samba-3895

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64):

ldapsmb-1.34b-5.3.1
libldb-devel-3.5.4-5.3.1
libldb0-3.5.4-5.3.1
libnetapi-devel-3.5.4-5.3.1
libnetapi0-3.5.4-5.3.1
libsmbclient-devel-3.5.4-5.3.1
libsmbclient0-3.5.4-5.3.1
libsmbsharemodes-devel-3.5.4-5.3.1
libsmbsharemodes0-3.5.4-5.3.1
libtalloc-devel-3.5.4-5.3.1
libtalloc2-3.5.4-5.3.1
libtdb-devel-3.5.4-5.3.1
libtdb1-3.5.4-5.3.1
libtevent-devel-3.5.4-5.3.1
libtevent0-3.5.4-5.3.1
libwbclient-devel-3.5.4-5.3.1
libwbclient0-3.5.4-5.3.1
samba-3.5.4-5.3.1
samba-client-3.5.4-5.3.1
samba-devel-3.5.4-5.3.1
samba-krb-printing-3.5.4-5.3.1
samba-winbind-3.5.4-5.3.1

- openSUSE 11.3 (x86_64):

libsmbclient0-32bit-3.5.4-5.3.1
libtdb1-32bit-3.5.4-5.3.1
libwbclient0-32bit-3.5.4-5.3.1
samba-32bit-3.5.4-5.3.1
samba-client-32bit-3.5.4-5.3.1
samba-winbind-32bit-3.5.4-5.3.1

- openSUSE 11.3 (noarch):

samba-doc-3.5.4-5.3.1


References:

https://bugzilla.novell.com/602418
https://bugzilla.novell.com/606304
https://bugzilla.novell.com/625936
https://bugzilla.novell.com/637755
https://bugzilla.novell.com/640870
https://bugzilla.novell.com/654719
https://bugzilla.novell.com/656112
https://bugzilla.novell.com/661842


< Previous Next >
This Thread
  • No further messages