Mailinglist Archive: opensuse-updates (35 mails)

< Previous Next >
openSUSE-SU-2011:0082-1 (important): tomcat6: fixing a XSS vulnerability (CVE-2010-4172)
openSUSE Security Update: tomcat6: fixing a XSS vulnerability (CVE-2010-4172)
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0082-1
Rating: important
References: #655440
Cross-References: CVE-2010-4172
Affected Products:
openSUSE 11.3
openSUSE 11.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update fixes a cross-site scripting vulnerability that
affects the session list screen. This can be used to steal
session cookies because tomcat 6 does not use the httpOnly
flag for its cookies. (CVE-2010-4172)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch tomcat6-3849

- openSUSE 11.2:

zypper in -t patch tomcat6-3849

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (noarch):

tomcat6-6.0.24-5.8.2
tomcat6-admin-webapps-6.0.24-5.8.2
tomcat6-docs-webapp-6.0.24-5.8.2
tomcat6-el-1_0-api-6.0.24-5.8.2
tomcat6-javadoc-6.0.24-5.8.2
tomcat6-jsp-2_1-api-6.0.24-5.8.2
tomcat6-lib-6.0.24-5.8.2
tomcat6-servlet-2_5-api-6.0.24-5.8.2
tomcat6-webapps-6.0.24-5.8.2

- openSUSE 11.2 (noarch):

tomcat6-6.0.20-24.27.2
tomcat6-admin-webapps-6.0.20-24.27.2
tomcat6-docs-webapp-6.0.20-24.27.2
tomcat6-javadoc-6.0.20-24.27.2
tomcat6-jsp-2_1-api-6.0.20-24.27.2
tomcat6-lib-6.0.20-24.27.2
tomcat6-servlet-2_5-api-6.0.20-24.27.2
tomcat6-webapps-6.0.20-24.27.2


References:

http://support.novell.com/security/cve/CVE-2010-4172.html
https://bugzilla.novell.com/655440


< Previous Next >
This Thread
  • No further messages