Mailinglist Archive: opensuse-updates (35 mails)

< Previous Next >
openSUSE-YU-2011:0056-1 (important): Software Update Stack Update 2011/01
openSUSE YOU Update: Software Update Stack Update 2011/01
______________________________________________________________________________

Announcement ID: openSUSE-YU-2011:0056-1
Rating: important
References: #431854 #448736 #577118 #593617 #594850 #599154
#607572 #607583 #613304 #619196 #635596 #650822

Affected Products:
openSUSE 11.2
______________________________________________________________________________

An update that has 12 YOU fixes can now be installed. It
includes three new package versions.

Description:

This is a collective update for the SUSE Software Update
Stack, including fixes for the following reports:

zypper:

- 448736: Better error message for non-root search for
outdated repo
- 619196: Fix zypper's password dialog
- 650822: Exit with error if zypper repo modification failed

libsatsolver:

- updateinfoxml: Correctly parse 'issued date' field.


libzypp:
- Implement support for patch category "feature"
- 431854: Yast2 sw_single and zypper don't handle failed
package downloads properly - commit doesn't report an
error
- 577118: Ignore an update in Software Updater
- 593617: Always refresh a repository if last refresh has a
date in the future
- 594850: Packages From Added Iso Image Are Not Available
- 607572: Edition with epoch 0 and without epoch are not
treated as being equal.
- 607583: Packages built via .drpms may get stored outside
or in a wrong package cache.
- 613304: libzypp fails to execute uuidgen
- 635596: zypper in --download-only doesn't download


Special Instructions and Notes:

Please reboot the system after installing this update.This
update triggers a restart of the software management stack.
More updates will be available for installation after
applying this update and restarting the application. This
update triggers a restart of the software management stack.
More updates will be available for installation after
applying this update and restarting the application.

Patch Instructions:

To install this openSUSE YOU Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.2:

zypper in -t patch softwaremgmt-201101-3745

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.2 (i586 x86_64) [New Version: 0.14.18,1.3.11 and 6.34.0]:

libsatsolver-demo-0.14.18-0.1.1
libsatsolver-devel-0.14.18-0.1.1
libzypp-6.34.0-0.1.1
libzypp-devel-6.34.0-0.1.1
perl-satsolver-0.14.18-0.1.1
python-satsolver-0.14.18-0.1.1
ruby-satsolver-0.14.18-0.1.1
satsolver-tools-0.14.18-0.1.1
zypper-1.3.11-0.1.1


References:

https://bugzilla.novell.com/431854
https://bugzilla.novell.com/448736
https://bugzilla.novell.com/577118
https://bugzilla.novell.com/593617
https://bugzilla.novell.com/594850
https://bugzilla.novell.com/599154
https://bugzilla.novell.com/607572
https://bugzilla.novell.com/607583
https://bugzilla.novell.com/613304
https://bugzilla.novell.com/619196
https://bugzilla.novell.com/635596
https://bugzilla.novell.com/650822


< Previous Next >
This Thread
  • No further messages