Mailinglist Archive: opensuse-updates (57 mails)

< Previous Next >
openSUSE-SU-2010:0354-1 (important): KVIrc: format string and directory traversal vulnerability
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Mon, 5 Jul 2010 15:08:10 +0200 (CEST)
  • Message-id: <20100705130810.550A4BE26@xxxxxxxxxxxxxx>
openSUSE Security Update: KVIrc: format string and directory traversal
vulnerability
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0354-1
Rating: important
References: #613163
Cross-References: CVE-2010-2451 CVE-2010-2452
Affected Products:
openSUSE 11.2
openSUSE 11.1
openSUSE 11.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update of KVirc fixes a remotely exploitable format
string and directory traversal vulnerability
(CVE-2010-2451, CVE-2010-2452).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.2:

zypper in -t patch kvirc-2642

- openSUSE 11.1:

zypper in -t patch kvirc-2642

- openSUSE 11.0:

zypper in -t patch kvirc-2642

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.2 (i586 src x86_64):

kvirc-3.4.2-4.6.1

- openSUSE 11.2 (i586 x86_64):

kvirc-devel-3.4.2-4.6.1

- openSUSE 11.1 (i586 ppc src x86_64):

kvirc-3.4.2-2.25.1

- openSUSE 11.1 (i586 ppc x86_64):

kvirc-devel-3.4.2-2.25.1

- openSUSE 11.0 (i586 ppc src x86_64):

kvirc-3.2.6-186.2

- openSUSE 11.0 (i586 ppc x86_64):

kvirc-devel-3.2.6-186.2


References:

http://support.novell.com/security/cve/CVE-2010-2451.html
http://support.novell.com/security/cve/CVE-2010-2452.html
https://bugzilla.novell.com/613163


< Previous Next >
This Thread
  • No further messages