Mailinglist Archive: opensuse-testing (44 mails)

< Previous Next >
[opensuse-testing] 12.1 M5 installation - my first experiences
Actually, M5 is my first attempt to install 12.1, and here are my first exeperiences today.

On beforehand, I had a properly working openSUSE Tumbleweed/Gnome x86_64 installed on /dev/sda1 and also openSUSE 11.4/Gnome x86_64 installed on /dev/sdc3, both in dual boot on my Asus M4A89 GTD Pro/USB3 based machine with a scsi and a sata disk.

1. First I tried a 12.1 M5 Update installation from NET-DVD on the 11.4/sdc3 system disk.
This resulted in a broken grub boot menu that didn't work:

Kernel (hd0,2)/boot/vmlinuz-3.0.0-4-desktop root=/dev/sdc3 ....
Error 22: No such partition

2. Afterwards I also tried a 12.1 M5/Gnome3 New Installation, and got the same error.

3. Doing a Rescue logon and mounting /dev/sdc3, the first sections of the /boot/grub/menu.lst showed me:

# Modified by YaST2. Last modification on lø. sep. 10 18:01:39 CEST 2011
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd2,2)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 12.1 Milestone 5 - 3.0.0-4
kernel (hd0,2)/boot/vmlinuz-3.0.0-4-desktop root=/dev/sdc3 resume=/dev/disk/by-id/scsi-200e09e0000baec4c-part1 splash=silent quiet showopts vga=0x31a
initrd (hd0,2)/boot/initrd-3.0.0-4-desktop

That is, while fxmenu points to the right disk (hd2,2),
both the kernel line and initrd line have got wrong disk designation (hd0,2)
and the same errors occure in the Failsafe section not showed here.
This is a new bug in 12.1, as both 11.4 and Tumbleweed have worked correct.

4. I edited menu.lst manually and corrected (hd0,2) to (hd2,2):

5. Then tried to boot Desktop openSUSE 12.1 M5 - 3.0.0-4
which just gave me a black screen (and nothing more visible) after the first display message 'Doing fast boot'

6. I was able to boot using Failsafe mode and got the GDM login menu. At the first logon attempt, I got some error messages:

Gnome 3 could not start correct and starts in 'Reserve' mode. The system, graphic hardware or driver don't support Gnome 3. At later login attempts in Failsafe mode, I don't got these errors, and am able to logon to the desktop. But the resolution is wrong, 1450x1050 maximum (should be 1920x1080) and the screen size is somewhat too small and doesn fill the display.

This is where I am currently with 12.1 M5/Gnome 3.

Comments to this, known bugs or similar experiences?

Terje J. Hanssen

To unsubscribe, e-mail: opensuse-testing+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-testing+help@xxxxxxxxxxxx

< Previous Next >
This Thread