Mailinglist Archive: opensuse-support (176 mails)

< Previous Next >
Re: [opensuse-support] yast install
On 15/02/2019 11.58, jdd@xxxxxxxxx wrote:
hello,

I'm still in the way of restoring a 42.3 system (see thread catastrofic
update), but now the system boots 42.3. Not in graphic mode, nor with
networks, but it boots.

I can access it via rescue system (chrooted), the main system provide
networks.

but if zypper works, yast don't

 # yast
/sbin/yast: /usr/lib/YaST2/bin/y2start: /usr/bin/ruby: bad interpreter:
No such file or directory

reinstalling ruby don't solve the problem

You have rpms of conflicting versions.


Run this:

rpm -q -a --queryformat "%{INSTALLTIME}\t%{INSTALLTIME:day} \
%{BUILDTIME:day} %-30{NAME}\t%15{VERSION}-%-7{RELEASE}\t%{arch} \
%25{VENDOR}%25{PACKAGER} == %{DISTRIBUTION} %{DISTTAG}\n" \
| sort | cut --fields="2-" | tee rpmlist \
| egrep -v "openSUSE\ Leap\ 42\.3|openSUSE_Leap_42\.3" | less -S


See what it finds.

--
Cheers / Saludos,

Carlos E. R.
(from 15.0 x86_64 at Telcontar)

< Previous Next >
Follow Ups
References