Mailinglist Archive: opensuse-support (220 mails)

< Previous Next >
Re: [opensuse-support] Perl problem in SpamAssassin, uninitialized value.
On 29/01/2019 13.06, David Haller wrote:
Hello,

On Tue, 29 Jan 2019, Carlos E. R. wrote:
On 29/01/2019 12.02, David Haller wrote:
https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7339

Thus it is a known bug upstream, and I don't need to report it on our
bugzilla. Thanks.

It looks like it.

Or is a patch needed?

No idea.

Wait, it was reported on 2016. Still not solved? :-o

No, I think it was supposed to be solved by requiring a newer version
of Net::DNS, i.e. Net::DNS >= 0.73.

What is the output of:
perl -MNet::DNS -e 'print "$Net::DNS::VERSIONn";'

cer@Telcontar:~> perl -MNet::DNS -e 'print "$Net::DNS::VERSIONn";'
cer@Telcontar:~>

Darn. There's a backslash gone amiss somewhen.

$ perl -MNet::DNS -e 'print "$Net::DNS::VERSION\n";'

last chars: O N backslash n quote semicolon apostrophe

cer@Telcontar:~> perl -MNet::DNS -e 'print "$Net::DNS::VERSION\n";'
1.14
cer@Telcontar:~>

That's more recent than 0.73, right?


What SUSEn do you use?

The one in the signature, 15.0

I had that deleted when typing ;(. Ok, according to sw.o.o, you
_should_ have perl-Net-DNS 1.14 installed. Which should be new enough.

But I have the problem...


But better check what your perl actually picks up, see above cmdline.
Could be some old Net/DNS.pm somewhere left over in an overriding
PERL5LIB path you've forgotten about years ago (/usr/local, ~/, ...
check your PERL5LIB env-var too, and any sh-rc-files you mucked about
in /etc/ like /etc/profile.local, /etc{,/*sh}/*shrc, and such ;)

cer@Telcontar:~> locate Net/DNS.pm
/data/main_root_bck/000/usr/lib/perl5/vendor_perl/5.18.2/x86_64-linux-thread-multi/Net/DNS.pm
/data/main_root_bck/001/usr/lib/perl5/vendor_perl/5.18.2/x86_64-linux-thread-multi/Net/DNS.pm
/data/main_root_bck/002/usr/lib/perl5/vendor_perl/5.26.1/Net/DNS.pm
/data/storage_b/Grande/copia/test_a__factory_10.2/usr/lib/perl5/vendor_perl/5.8.8/i586-linux-thread-multi/Net/DNS.pm
/data/storage_d/copia_storage_e/Images_main_at_114/copia_main_usr/lib/perl5/vendor_perl/5.12.3/x86_64-linux-thread-multi/Net/DNS.pm
/data/storage_d/para_quemar/cmp/test_a__factory_10.2/usr/lib/perl5/vendor_perl/5.8.8/i586-linux-thread-multi/Net/DNS.pm
/other/ssd-test/usr/lib/perl5/vendor_perl/5.26.1/Net/DNS.pm
/usr/lib/perl5/vendor_perl/5.26.1/Net/DNS.pm
cer@Telcontar:~>

There is only one. The others are backups.



Also helpful: start up "cpan" and then enter "m Net::DNS" at it's
prompt. Should look something like this (I maintain my own perl in ~/
currently):

cer@Telcontar:~> cpan

CPAN.pm requires configuration, but most of it can be done automatically.
If you answer 'no' below, you will enter an interactive dialog for each
configuration option instead.

Would you like to configure as much as possible automatically? [yes]

At this point I aborted.

--
Cheers / Saludos,

Carlos E. R.
(from 15.0 x86_64 at Telcontar)

< Previous Next >