Mailinglist Archive: opensuse-support (220 mails)

< Previous Next >
Re: [opensuse-support] Broken "pin" command in 15.0
  • From: Knurpht-openSUSE <knurpht@xxxxxxxxxxxx>
  • Date: Thu, 24 Jan 2019 02:17:18 +0100
  • Message-id: <1610080.d9AumjMpIu@knurpht-hp>
Op donderdag 24 januari 2019 01:54:54 CET schreef Christian Boltz:
Hello,

Am Mittwoch, 23. Januar 2019, 15:07:08 CET schrieb Carlos E. R.:
cer@Telcontar:~> pin Gray_A.icc
/usr/bin/pin: command substitution: line 89: unexpected EOF while
looking for matching `"' /usr/bin/pin: command substitution: line 90:
syntax error: unexpected end of file

*** pin found no ARCHIVES_"".gz file in /var/lib/pin/

pin will copy the files, please enter root password :
Password:


File ARCHIVES.gz does exist.




The offending lines are:

[ -f /etc/SuSE-release ] && USED_VERSION="`grep VERSION
/etc/SuSE-release | cut -f3 -d " "`" [ -z ${USED_VERSION} ] &&
USED_VERSION="`grep VERSION_ID /etc/os-release | cut -f3 -d "\""`"

Interestingly, there was already a Leap maintenance update attemping to
fix this by adding this line (boo#1095723), but it uses the wrong column
for /etc/os-release - cut -f2 would be right.

cer@Telcontar:~> grep VERSION_ID /etc/os-release
VERSION_ID="15.0"
cer@Telcontar:~> grep VERSION_ID /etc/os-release | cut -f3 -d "\""

That's an obvious bug, and my usual recommendation would be to open a
bugreport.

However, this smelled like a small issue, so I decided to simply fix it.

Well, as usual if I touch something, it explodes ;-) and in the end, I
did 3 fixes instead of one - see my comment in boo#1095723 for details.

I initially considered to submit the Tumbleweed package to Leap (which
claims to have this fixed in a different way), but it turned out that it
was broken in a different way ;-)

Carlos, can you please test if pin from
a) https://build.opensuse.org/request/show/668206 (for Leap)
b) https://build.opensuse.org/request/show/668208 (for Tumbleweed)
works for you now? Ideally test both because they use different ways to
read /etc/os-release. (If you don't want to install the package - simply
downloading and running "pin" from OBS is enough to test it.


Regards,

Christian Boltz
404, can't find a way to download the package.



--
To unsubscribe, e-mail: opensuse-support+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-support+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups