Mailinglist Archive: opensuse-support (116 mails)

< Previous Next >
Re: [opensuse-support] LibreOffice cannot be started by normal user but no problem by root
  • From: H Zeng <zhx@xxxxxxxxx>
  • Date: Fri, 28 Dec 2018 09:19:54 +0800
  • Message-id: <9259496.HTRTvYdh4o@ostp>
On Friday, 28 December 2018 02:17:51 HKT Carlos E. R. wrote:
On 27/12/2018 16.59, H Zeng wrote:
On Thursday, 27 December 2018 23:29:06 HKT Carlos E. R. wrote:
On 27/12/2018 15.32, H Zeng wrote:
Then, the question is that how could I make LO also works by normal
user.

I have no clue where to start trying. Any suggestions are welcome!

Maybe mount options of the /home partition? Run "mount" in a terminal to
find out.

```bash
cnzhx@ostp:/home/cnzhx> mount | grep home
/dev/nvme0n1p7 on /home type ext4 (rw,noatime,data=ordered)
```
Is this OK?

AFAIK, yes. If it were "noexec" we could suspect that, but it isn't. Nor
"ro".

Anything by apparmor? Run "aa-logprof" as root to see what it complains
about.

```bash
cnzhx@ostp:/home/cnzhx> sudo aa-logprof
[sudo] password for root:
Reading log entries from /var/log/audit/audit.log.
Updating AppArmor profiles in /etc/apparmor.d.
```

And this is empty, so nothing was blocked.

Thank you, Carlos. Could you find anything unusual from the outputs?

No... :-(
This situation is very strange but it seems not a bug so I have not reported
it. This is far beyond my knowledge. I guess I just have to reinstall my
system again.

In the last reinstallation of openSUSE Tumbleweed, the installer did not
remind me to scan and import existing users from existing /home partition. I
skipped the user creation and create a new user with the same old username
with the old user dir as it's home dir. Do you think this could possibly be
the cause of my current issue? If yes, is there anything I can do to find out?

--

Best regards,
ZHX


--
To unsubscribe, e-mail: opensuse-support+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-support+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups