Mailinglist Archive: opensuse-support (116 mails)

< Previous Next >
[opensuse-support] LibreOffice cannot be started by normal user but no problem by root
  • From: H Zeng <zhx@xxxxxxxxx>
  • Date: Thu, 27 Dec 2018 22:32:05 +0800
  • Message-id: <2129819.oXOMdWhSkc@ostp>
Hi there,

I had posted a startup problem with LibreOffice recently. But mistakenly, I
had posted it in a hijacking way. Thanks to Carlos for pointing out this and
providing me some ideas along with other people. So I start a new thread
because I need further help on this issue and here are something new I found
on my problem. And the direction to solve the problem seems changed.

For reference, following is the links to the posts in the hijacked thread:
[1] https://lists.opensuse.org/opensuse-support/2018-12/msg00055.html
[2] https://lists.opensuse.org/opensuse-support/2018-12/msg00065.html

First of all, I can confirm that the issue is not with Java. I fired up a
VirtualBox and installed openSUSE Tumbleweed in it with almost all settings as
default. LibreOffice runs smoothly without further setup, just like my current
system.

Here are something new,
1. LibreOffice does not run in a newly created account in my system. The error
messages are the same.
2. I have already tried to remove LibreOffice and reinstall all related
packages and this does not help.
3. It seems that LibreOffice can run by root,
```bash
cnzhx@ostp:/home/cnzhx> libreoffice --version
terminate called after throwing an instance of
'com::sun::star::uno::RuntimeException'
```
```bash
cnzhx@ostp:/home/cnzhx> sudo libreoffice --version
LibreOffice 6.1.3.2 10(Build:2)
```

Then, the question is that how could I make LO also works by normal user.

I have no clue where to start trying. Any suggestions are welcome!

--

Best regards,
ZHX


--
To unsubscribe, e-mail: opensuse-support+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-support+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups