Mailinglist Archive: opensuse-support (116 mails)

< Previous Next >
Re: [opensuse-support] Re: Libreoffice not start in a newly installed openSUSE Tumbleweed with old user directory
  • From: Bruno Friedmann <bruno@xxxxxxxxxxx>
  • Date: Mon, 24 Dec 2018 10:33:48 +0100
  • Message-id: <12590256.6NA9utR0Oo@qt-kt>
On lundi, 24 décembre 2018 04.31:26 h CET H Zeng wrote:
On Friday, 21 December 2018 09:11:02 HKT you wrote:
Hello,

I reinstalled my openSUSE Tumbleweed w/ KDE Plasma because my root
partition failed. After the reinstallation, Libreoffice does not start.
If trying to start it from command line, complaints are like these,
```bash
cnzhx@ostp:/home/cnzhx> libreoffice --safe-mode
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
terminate called after throwing an instance of
'com::sun::star::uno::RuntimeException'


Fatal exception: Signal 6
Stack:
/usr/lib64/libreoffice/program/libuno_sal.so.3(+0x15433)[0x7fe3f582d433]
/usr/lib64/libreoffice/program/libuno_sal.so.3(+0x15657)[0x7fe3f582d657]
/lib64/libc.so.6(+0x38110)[0x7fe3f1b27110]
/lib64/libc.so.6(gsignal+0x10b)[0x7fe3f1b2708b]
/lib64/libc.so.6(abort+0x123)[0x7fe3f1b104e9]
/usr/lib64/libstdc++.so.6(+0x94973)[0x7fe3f1614973]
/usr/lib64/libstdc++.so.6(+0x9a8c8)[0x7fe3f161a8c8]
/usr/lib64/libstdc++.so.6(+0x9a913)[0x7fe3f161a913]
/usr/lib64/libstdc++.so.6(+0x9ab43)[0x7fe3f161ab43]
/usr/lib64/libreoffice/program/libmergedlo.so(+0xcff752)[0x7fe3f2bae752]
/usr/lib64/libreoffice/program/libmergedlo.so(+0x102b391)[0x7fe3f2eda391]
/usr/lib64/libreoffice/program/libmergedlo.so(+0x2a6114d)[0x7fe3f491014d]
/usr/lib64/libreoffice/program/libmergedlo.so(+0x16e8ae5)[0x7fe3f3597ae5]
/usr/lib64/libreoffice/program/libmergedlo.so(+0x16e8e97)[0x7fe3f3597e97]
/usr/lib64/libreoffice/program/
libmergedlo.so(_ZN3utl10ConfigItemC2ERKN3rtl8OUStringE14ConfigItemMode+0x8
5) [0x7fe3f3598035]
/usr/lib64/libreoffice/program/
libmergedlo.so(_ZN19SvtSysLocaleOptionsC1Ev+0x189)[0x7fe3f35c15d9]
/usr/lib64/libreoffice/program/libmergedlo.so(+0x14453f6)[0x7fe3f32f43f6]
/usr/lib64/libreoffice/program/libvclplug_gtk3_kde5lo.so(+0x9f5c1)
[0x7fe3eb2095c1]
/usr/lib64/libreoffice/program/libmergedlo.so(_Z7InitVCLv+0x6d2)
[0x7fe3f328dac2]
/usr/lib64/libreoffice/program/libmergedlo.so(_Z6SVMainv+0x245)
[0x7fe3f328dda5]
/usr/lib64/libreoffice/program/libmergedlo.so(soffice_main+0x18a)
[0x7fe3f3f99fda]
/usr/lib64/libreoffice/program/soffice.bin(+0x107b)[0x564481ad307b]
/lib64/libc.so.6(__libc_start_main+0xeb)[0x7fe3f1b11feb]
/usr/lib64/libreoffice/program/soffice.bin(+0x10ba)[0x564481ad30ba]
```

Could anyone please help on solving this problem?

I tried several ways to fix it but failed.

1. Installing "libreoffice-gtk2" won't help when I followed tips from
https:// bbs.archlinux.org/viewtopic.php?id=206869
"libreoffice-gtk3" won't help either.

2. Installing "libreoffice-base" solves the error messages (the first 2
lines) related to javaldx.

3. Removing all "libreoffice-*" packages and reinstalling "libreoffice"
won't help either after the hint from here:
https://bugs.launchpad.net/ubuntu/
+source/libreoffice/+bug/1768756/comments/6

4. Same symptoms occur when test LO in a newly created account in the same
system (newly installed openSUSE Tumbleweed snapshot 20181214 upgraded to
20181219).

Please help on solving this problem. To work without LO is very difficult.

Hi ZHX, as libreoffice is working quite well here, I give you what is
installed on my system
zypper se -si libreoffice give those installed package
S | Name | Type | Version | Arch |
---+-------------------------------------+---------+-------------+--------
i+ | libreoffice | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-base | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-base-drivers-postgresql | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-branding-upstream | package | 6.1.3.2-4.1 | noarch |
i+ | libreoffice-calc | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-calc-extensions | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-draw | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-filters-optional | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-gdb-pretty-printers | package | 6.1.3.2-4.1 | noarch |
i+ | libreoffice-gnome | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-gtk3 | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-icon-themes | package | 6.1.3.2-4.1 | noarch |
i+ | libreoffice-impress | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-l10n-en | package | 6.1.3.2-4.1 | noarch |
i+ | libreoffice-mailmerge | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-math | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-pyuno | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-qt5 | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-share-linker | package | 1-4.4 | noarch |
i+ | libreoffice-writer | package | 6.1.3.2-4.1 | x86_64 |
i+ | libreoffice-writer-extensions | package | 6.1.3.2-4.1 | x86_64 |

I'm using plasma5 under X11 due to nvidia, so -qt5 is installed, adapt to your
own env.

On java side I've 2 versions installed
S | Name | Type | Version | Arch |
---+-----------------------------+---------+---------------+--------
i | java-11-openjdk | package | 11.0.1.0-2.1 | x86_64 | oss
i+ | java-11-openjdk-headless | package | 11.0.1.0-2.1 | x86_64 | oss
i | java-1_8_0-openjdk | package | 1.8.0.181-1.1 | x86_64 | oss
i+ | java-1_8_0-openjdk-devel | package | 1.8.0.181-1.1 | x86_64 | oss
i | java-1_8_0-openjdk-headless | package | 1.8.0.181-1.1 | x86_64 | oss
i+ | java-1_8_0-openjdk-src | package | 1.8.0.181-1.1 | x86_64 | oss

In libreoffie java-11 is the one selected by default.

You didn't tell us when you start in safe mode if you've tried to disable
openCL openGL and also if you have any kind of extension installed (system
and/or user)

Also try to check https://wiki.documentfoundation.org/QA/BugReport

If you want to debug it (and report upstream or bugzilla.opensuse.org)
you can start it in gdb with

gdb /usr/lib64/libreoffice/program/soffice.bin
run --safe-mode

(when it crash)
thread apply at bt

(Your backtrace to be complete, you have to install all debuginfo that gdb
will ask you for example )
Missing separate debuginfo for /usr/lib64/gdk-pixbuf-2.0/2.10.0/loaders/
libpixbufloader-png.so
Try: zypper install -C "debuginfo(build-
id)=07941dcb9a1daf9f437754dbf5d91c594cff84c4"



--

Bruno Friedmann
Ioda-Net Sàrl www.ioda-net.ch
Bareos Partner, openSUSE Member, fsfe supporter
GPG KEY : D5C9B751C4653227
irc: tigerfoot




--
To unsubscribe, e-mail: opensuse-support+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-support+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups