Mailinglist Archive: opensuse-support (116 mails)

< Previous Next >
[opensuse-support] TW fails compatibility with amdgpu graphics driver
After my tumbleweed upgrade last week, I am no longer able to boot into my system unless I use the 'nomodeset' configuration. In that case, I cannot get into a graphical target at all.

This has only happened since the kernel upgrade to 4.19.

Here is my hardware information

# hwinfo --gfxcard
23: PCI 300.0: 0380 Display controller
[Created at pci.378]
Unique ID: svHJ.+ug88O0PpPA
Parent ID: w+J7.XZwpGIabNM5
SysFS ID: /devices/pci0000:00/0000:00:03.1/0000:03:00.0
SysFS BusID: 0000:03:00.0
Hardware Class: graphics card
Model: "ATI Baffin [Radeon RX 460]"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x67ef "Baffin [Radeon RX 460]"
SubVendor: pci 0x1028 "Dell"
SubDevice: pci 0x07e2
Revision: 0xff
Driver: "amdgpu"
Driver Modules: "amdgpu"
Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
Memory Range: 0xf0000000-0xf01fffff (ro,non-prefetchable)
I/O Ports: 0xd000-0xdfff (rw)
Memory Range: 0xfe800000-0xfe83ffff (rw,non-prefetchable)
Memory Range: 0xfe840000-0xfe85ffff (ro,non-prefetchable)
IRQ: 230 (67 events)
Module Alias: "pci:v00001002d000067EFsv00001028sd000007E2bc03sc80i00"
Driver Info #0:
Driver Status: amdgpu is active
Driver Activation Cmd: "modprobe amdgpu"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #22 (PCI bridge)

28: PCI 01.0: 0300 VGA compatible controller (VGA)
[Created at pci.378]
Unique ID: vSkL.gwUVE8uFOP6
SysFS ID: /devices/pci0000:00/0000:00:01.0
SysFS BusID: 0000:00:01.0
Hardware Class: graphics card
Model: "ATI Carrizo"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x9874 "Carrizo"
SubVendor: pci 0x1028 "Dell"
SubDevice: pci 0x07e2
Revision: 0xcc
Driver: "amdgpu"
Driver Modules: "amdgpu"
Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
Memory Range: 0xf0800000-0xf0ffffff (ro,non-prefetchable)
I/O Ports: 0xf000-0xf0ff (rw)
Memory Range: 0xfea00000-0xfea3ffff (rw,non-prefetchable)
Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
IRQ: 228 (49683 events)
Module Alias: "pci:v00001002d00009874sv00001028sd000007E2bc03sc00i00"
Driver Info #0:
Driver Status: amdgpu is active
Driver Activation Cmd: "modprobe amdgpu"
Config Status: cfg=no, avail=yes, need=no, active=unknown

Primary display adapter: #28

Here is what my system is using:
# lspci -nnk | grep -A3 VGA
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Carrizo [1002:9874] (rev cc)
Subsystem: Dell Device [1028:07e2]
Kernel driver in use: amdgpu
Kernel modules: amdgpu

I tried to boot without nomodeset, and even though it does get to a point where I can type in my login id, it locks up soon after, whether or not I try to log in. It does not reach the display manager. I was not able to boot up to run level 3, though I only tried it once.

Also, it does not create an Xorg.0.log file. Or rather, it creates one, but it is completely empty.

I think there may be some compatibility issues within the new kernel and my hardware, perhaps? In any case, how can I get back into my system? Can I even reach runlevel 3 with network compatibility so that I could try and upgrade or downgrade my kernel while running in nomodeset?

Do I need to file a bug report?

--
George
Box: 42.3 | KDE Plasma 5.8 | AMD Phenom IIX4 | 64 | 32GB
Laptop #1: TW | Plasma 5.13 | AMD FX 7TH GEN | 64 | 32GB
Laptop #2: TW | Plasma 5.13 | Core i5 | 64 | 8GB
--
To unsubscribe, e-mail: opensuse-support+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-support+owner@xxxxxxxxxxxx

< Previous Next >