Mailinglist Archive: opensuse-support (80 mails)

< Previous Next >
Re: [opensuse-support] lost hplip printing
On 15/10/2018 22.10, Patrick Shanahan wrote:
* Carlos E. R. <> [10-15-18 15:45]>> On Monday, 2018-10-15 at 15:08 -0400,
Patrick Shanahan wrote:

tumbleweed uptodate
hplip-3.18.6-1.1.x86_64
HP OfficeJet Pro 8620

configured wireless static 192.168.1.12

printer worked fine until yesterday and the only changes I have made are
tumbleweed updates using dup.


can print to this printer from three windows 10 machines
can ping 192.168.1.12 from three windows 10 machines

cannot ping from 3 tw and one 42.2 box

That rules out cups stack or hplip.

I assume you can ping other machines? Ah, yes, I see you can print to
another printer.

This printer is on wifi?

yes, both are.

the 8620/192.168.1.12 failed to print and in trying to reconfigure, I
removed the printer using the hplip interface, but cannot reconfigure or
read subject printer.

No, I don't think this is an hplip issue, as long as you can not even
ping the printer.


hp-setup cannot detect printer, 192.168.1.12, on my network from 4
openSUSE boxes.

firewall off makes no difference

I can setup the printer from yast and from localhost:631 but cannot print.

I am lost, what to do next?


fwiw, I have another networked printer, 192.168.1.197, HP OfficeJet Pro
8615, and can print to it from all boxes and can ping it from all boxes.

tks,

I would reboot the printer, first of all.

have done that several times, doing again, also removed power cord. I
waited >15 minutes and reattached power and started device

ip n show:
192.168.1.12 dev enp0s25 lladdr 6c:c2:17:1d:2f:26 REACHABLE
but changes in about 60 seconds to:
192.168.1.12 dev enp0s25 lladdr 6c:c2:17:1d:2f:26 STALE

and no change in efforts with hp-setup


My HP printer sometimes does that, refuse to print and needs a kick.


Next, I would check the configuration of the printer to ensure that it is
still 192.168.1.12 - if it changed, I guess Windows can find it anyway.

I deliberately changed it earlier with same result from all boxes
(192.168.1.75) and changed it back.

I meant using the printer panel itself, not the computer.

You should also be able to browse to http://192.168.1.12 in firefox or
similar.



Next, try ping to the printer.

believe I said that. can from several windows 10 boxes but cannot from
any linux box.

and still cannot after repowering.

Well, you have a network issue. You could try then a traceroute.
Try also to reboot the WiFi access point and/or router.


--
Cheers / Saludos,

Carlos E. R.
(from 42.3 x86_64 "Malachite" at Telcontar)

< Previous Next >
Follow Ups