Mailinglist Archive: opensuse-support (91 mails)

< Previous Next >
[opensuse-support] question about ldd

    Hi,

        I'm still trying to figure out why I can't get fahclient to run, and I found out that ldd shows which libraries

are needed by a program. Now I'm really no linux expert (or even close) so I'm trying things that I hope will

not cause any system damage.  This is the output of ldd FAHClient

./FAHClient: /usr/lib64/libssl.so.10: version `libssl.so.10' not found (required by ./FAHClient)
./FAHClient: /usr/lib64/libcrypto.so.10: version `OPENSSL_1.0.1_EC' not found (required by ./FAHClient)
./FAHClient: /usr/lib64/libcrypto.so.10: version `libcrypto.so.10' not found (required by ./FAHClient)
    linux-vdso.so.1 (0x00007ffcb07c6000)
    libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f2df40ab000)
    libssl.so.10 => /usr/lib64/libssl.so.10 (0x00007f2df3e3c000)
    libcrypto.so.10 => /usr/lib64/libcrypto.so.10 (0x00007f2df39d3000)
    libdl.so.2 => /lib64/libdl.so.2 (0x00007f2df37cf000)
    librt.so.1 => /lib64/librt.so.1 (0x00007f2df35c7000)
    libbz2.so.1 => /usr/lib64/libbz2.so.1 (0x00007f2df44a4000)
    libz.so.1 => /lib64/libz.so.1 (0x00007f2df33b0000)
    libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f2df4316000)
    libm.so.6 => /lib64/libm.so.6 (0x00007f2df301d000)
    libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f2df42fc000)
    libc.so.6 => /lib64/libc.so.6 (0x00007f2df2c5d000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f2df42ca000)

            So if I read this right, I have the necessary libs are installed, so why does it say that it can not

    find 3 of the libraries??


                    mike


--
To unsubscribe, e-mail: opensuse-support+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-support+owner@xxxxxxxxxxxx

< Previous Next >