Mailinglist Archive: opensuse-support (91 mails)

< Previous Next >
[opensuse-support] Re: KDE Plasma on Wayland with openSUSE Tumbleweed
  • From: H Zeng <zhx@xxxxxxxxx>
  • Date: Mon, 17 Sep 2018 22:30:18 +0800
  • Message-id: <7393516.ajJBCtWNQg@ostp>
Hello,

Regarding this issue, I found that I can start a Wayland session with root (I
have never logged in in graphic using root). Then I checked the log with
journalctl and found that the wayland login of the normal user, who used to
log in with X11 session, stopped (was hanging on) after following operation,
```
Sep 17 21:52:09 ostp systemd[1]: Starting Locale Service...
Sep 17 21:52:09 ostp dbus-daemon[1250]: [system] Successfully activated
service 'org.freedesktop.locale1'
Sep 17 21:52:09 ostp systemd[1]: Started Locale Service.
Sep 17 21:53:02 ostp systemd-logind[1287]: Power key pressed.
Sep 17 21:53:02 ostp systemd-logind[1287]: Powering Off...
```

But with root, I have,
```
Sep 17 21:45:03 ostp dbus-daemon[1250]: [system] Successfully activated
service 'org.freedesktop.locale1'
Sep 17 21:45:03 ostp systemd[1]: Started Locale Service.
Sep 17 21:45:03 ostp systemd[1]: Received SIGRTMIN+21 from PID 285
(plymouthd).
Sep 17 21:45:03 ostp systemd[1]: Started Hold until boot process finishes up.
Sep 17 21:45:03 ostp systemd[1]: Started Getty on tty1.
Sep 17 21:45:03 ostp systemd[1]: Reached target Login Prompts.
Sep 17 21:45:03 ostp sddm[1816]: Initializing...
Sep 17 21:45:03 ostp sddm[1816]: Starting...
Sep 17 21:45:03 ostp sddm[1816]: Logind interface found
Sep 17 21:45:03 ostp sddm[1816]: Adding new display on vt 7 ...
Sep 17 21:45:03 ostp sddm[1816]: Loading theme configuration from ""
Sep 17 21:45:03 ostp sddm[1816]: Display server starting...
```

But I do not want to fully re-config my current profile. Does anyone know what
I can do to make this user able to login using Wayland session without reset
its configuration (like .local, or .config folder). Besides, I already tried
to delete .cache folder.

TIA

On Monday, 17 September 2018 14:44:20 HKT you wrote:
Hello,

I just upgraded my Tumbleweed to the lastest 0915 snapshot and tried the
Plasma (wayland) but failed to enter the desktop. After select wayland
session and input my password to login, the screen turns black (seems no
backlight?) and the system does not repond to keystrokes. I have to press
the power button to poweroff the system.

I am using an (integrated ?) Intel GPU with Mesa driver.

Does anyone know what's going on? I thought Wayland is stable for at least a
try now, did it?

Best regards,
ZHX
--

Best regards,
ZHX


--
To unsubscribe, e-mail: opensuse-support+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-support+owner@xxxxxxxxxxxx

< Previous Next >
References