Mailinglist Archive: opensuse-support (56 mails)

< Previous Next >
[opensuse-support] ruby dependency installing machinery on TW
Recently after the last two TW snapshots, I now get this error
regarding machinery installation:

# zypper in machinery
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides rubygem(ruby:2.5.0:rack-protection) = 2.0.1
needed by ruby2.5-rubygem-sinatra-2.0.1-2.2.x86_64
Solution 1: do not install machinery-1.23.1-1.5.x86_64
Solution 2: break ruby2.5-rubygem-sinatra-2.0.1-2.2.x86_64 by ignoring
some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): c

I was hoping it would get resolved in the next snapshot or so. Any
ideas? I can use machinery from a VM running SLES or Leap so it's not
critical, just a small pain since I had it on my base laptop install.

Wayne

< Previous Next >