Mailinglist Archive: opensuse-support (71 mails)

< Previous Next >
Re: [opensuse-support] Just how crippled is 15.0 DVD rescue boot known to be?
  • From: Andrei Borzenkov <arvidjaar@xxxxxxxxx>
  • Date: Thu, 12 Jul 2018 09:32:41 +0300
  • Message-id: <CAA91j0X-fUrnM+Lmb+f+UxG+sjnEd6DQnQsuypW73PnSptFZ=Q@mail.gmail.com>
On Thu, Jul 12, 2018 at 7:32 AM, Felix Miata <mrmazda@xxxxxxxxxxxxx> wrote:
I selected rescue from DVD boot to try to fix a corrupted EFI configuration
after
installing OS X added another EFI system partition, which along with the rest
of
installed OS X partitions I deleted, then recreated to my specifications. I
expected
a GUI, but didn't get one. I used efibootmgr to reaffirm that openSUSE is
first in
list, but Mac BIOS apparently ignores it.

On Mac file must be "blessed" to be accepted by frmware. I think it is
possible to "bless" the whole partition (at least I vaguely remember I
did it). grub2 includes grub2-bless utility, you may try it.

I tried to fix it with YaST2 from another
rescue boot, but apparently YaST2 isn't on the 15.0 DVD. So I rebooted again
but
selected boot from HD. That fails with "error: no such device:
/dev/boot/fallback.efi."
So I rebooted again, this time typing in a complete Grub stanza from scratch,
but it
produced "error: can't find command 'load_video'; error: can't find command
'linux';
can't find command 'initrd'". I tried again but with linuxefi and initrdefi.
After
stumbling over can't find load_video again it proceeded to boot. What's the
secret
on a UEFI system to "repair" the bootloader or boot the installed system,
boot a
42.3 DVD?

|ID |ux|Dr|Type, description|Format |Related |VolumeLabel|OS2-LVM/BM / GPT /
Crypt / additional in| Size MiB |
+--</dev/sda MBR disk
1>--------+--------+-----------<ST1000DM003-1SB1>-----------------------+-----------+
|01 | 1| |Prim ee GPT-guard|Prot-MBR|GPT/EFI | | 74706daf
| 953869.7|
|02 | 1| |Windows BasicData|FAT16 |mkfs.fat|ST10-ESP |sda1 EFI System
(ESP) | 368.0|
|03 | 2| |Mac OS X HFS+ |unknown |macOS | |sda2 Mac OS X HFS+
system | 36750.0|
|04 | 3| |Mac OS X HFS+ |unknown |macOS | |sda3 Mac OS X HFS+
data | 440000.0|
|05 | 4| |Linux Swap |SWAP |LinuxV1 |SWAPSPACE2 |sda4 Linux Swap
| 4224.0|
|06 | 5| |Linux Data |EXT4 |Linux |st10suselea|sda5 openSUSE Leap
| 32526.0|
|07 | 6| |Linux Data |XFS |Linux | |sda6 Linux /home
| 440000.0|
|08 | | |Fsp + GPT pta/hdr|-- -- --|-- -- --|- - - - - -|Size 0x58f sectors
| 0.695|

# parted -l
Model: ATA ST1000DM003-1SB1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name
Flags
1 1049kB 387MB 386MB fat32 sda1 EFI System (ESP)
boot, hidden, esp
2 387MB 38.9GB 38.5GB sda2 Mac OS X HFS+ system
3 38.9GB 500GB 461GB sda3 Mac OS X HFS+ data
4 500GB 505GB 4429MB linux-swap(v1) sda4 Linux Swap
swap
5 505GB 539GB 34.1GB ext4 sda5 openSUSE Leap
6 539GB 1000GB 461GB xfs sda6 Linux /home

On boot with manually typed grub stanza I changed the Grub timeout in YaST2,
which
inexplicably created a new initrd identical to the existing one, but did fix
HD
booting at least until I install OS X again.

Also I looked for fallback.efi. The only place I found it was
/usr/lib64/efi/fallback.efi.
--
"Wisdom is supreme; therefore get wisdom. Whatever else you
get, get wisdom." Proverbs 4:7 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/
--
To unsubscribe, e-mail: opensuse-support+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-support+owner@xxxxxxxxxxxx

--
To unsubscribe, e-mail: opensuse-support+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-support+owner@xxxxxxxxxxxx

< Previous Next >
References