Mailinglist Archive: opensuse-support (159 mails)

< Previous Next >
Re: [opensuse-support] TW Grub EFI menu & memtest86+
On 06/20/2018 08:07 PM, Neil Rickert wrote:

I suggest you instead try using: efi/boot/bootx64.efi

Here is what I have since tried.

I created a directory "/boot/efi/EFI/memtest". Note that "/boot/efi" is
the mount point for the EFI partition, so that this is "EFI/memtest"
relative to the EFI partition.

I copied everything from CDROM/efi/boot/. to this new "memtest"
directory. I then did:

mv bootx64.efi memtest.efi
rm bootia32.efi

I then used, in grub.cfg:

--- cut here ---
menuentry 'memtest' {
insmod part_gpt
insmod fat
search --no-floppy --fs-uuid --set=root 8E66-F434
chainloader /efi/memtest/memtest.efi
}
--- cut here ---

I disabled secure-boot. And it worked.

NOTES: Since I am using "shim", those "insmod" probably don't do
anything because most modules are preloaded. If not using shim, you
might need other "insmod". However, I would guess that whatever grub
module is required to read the EFI partition is going to be preloaded
anyway.

That string "8E66-F434" is the UUID of the EFI partition. You would
need to change that as appropriate.

Did I mention that it seemed to work? I did stop it early.

I should add that this was all done in a KVM virtual machine (where Leap
15.0 is installed). I have not tried on real hardware.
--
To unsubscribe, e-mail: opensuse-support+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-support+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups