Mailinglist Archive: opensuse-security (15 mails)

< Previous Next >
Re: [opensuse-security] Problem with SLE11-SDK-SP2-Updates repo
  • From: Werner Flamme <werner.flamme@xxxxxx>
  • Date: Mon, 17 Jun 2013 14:26:50 +0200
  • Message-id: <51BF008A.20901@ufz.de>
Marcus Meissner [17.06.2013 13:19]:
On Mon, Jun 17, 2013 at 10:08:51AM +0100, Bob Vickers wrote:
I get this quite often too. I am guessing it happens because mirrors don't
get updated atomically, so sometimes a given mirror will have an
inconsistent set of files. If you wait a day or so it usually gets better.

It would be nice if there were a way of directing zypper to try different
mirrors, because I often find that zypper works on machine A but not on
machine B. Does anyone know how to do this?

There is some mirroring in the background via Akamai... However if the
problem persists, either one Akamai mirror is out of sync, or the repo
itself is out of sync.

It currently looks good for me on my server.

Can you check zypper.log which file had the incorrect checksum?

Marcus,

sorry, I can't :-(. "grep '2013-06-17 12' /var/log/zypper.log " gives
1940 lines, and they are very confusing, I cannot filter them for more
details.

The only place where I see errors in these lines they are talking about
the "repomd.xml" file, which was also printed in the error log I quoted
in <51BEE2F2.5040807@xxxxxx>.

The error persists for 5 days now - it often happens that I have a
"wrong checksum" error, but it's usually gone after a few hours. This
time it seems different, so I asked...

Regards,
Werner

--

--
To unsubscribe, e-mail: opensuse-security+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-security+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups