Mailinglist Archive: opensuse-security (50 mails)

< Previous Next >
Re: [opensuse-security] rpmdb: malloc: Cannot allocate memory: 4278
  • From: Christian Boltz <suse-security@xxxxxxxxx>
  • Date: Tue, 1 Jul 2008 02:45:19 +0200
  • Message-id: <200807010245.20855@xxxxxxxxxxxxxxx>
Hello,

Am Montag, 30. Juni 2008 schrieb Marcus Meissner:
It really sounds like an out of memory situation...

Interesting hint - I noticed that the swap was not activated (my fault).
I'm not sure if this was related to the problem.

Login a second time and watch with "top" or "free" to see if memory
is running out.

[deleting a very long text after trying several things]

Very interesting problem :-/

ulimit could be part of the problem.

# ulimit -a # as root
core file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
file size (blocks, -f) unlimited
pending signals (-i) 16375
max locked memory (kbytes, -l) 32
max memory size (kbytes, -m) 411960
open files (-n) 1024
pipe size (512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) 16375
virtual memory (kbytes, -v) 411960
file locks (-x) unlimited

Cross-checked - another 10.2 server has nearly the same settings except
virtual memory (kbytes, -v) 831240
and zypper up worked there.


Finally good news: After changing the ulimit for virtual memory, the
update worked :-)

Thanks for your help and hints!


Regards,

Christian Boltz
--
Es ist Fakt, dass ein Bug ziemlich oft zwischen Stuhllehne und
Tastatur sitzt. [Thomas Hertweck in suse-linux]
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-security+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security+help@xxxxxxxxxxxx

< Previous Next >
List Navigation
This Thread
  • No further messages