Mailinglist Archive: opensuse-security (88 mails)

< Previous Next >
SuSE 10.0 yast2 vpn module seg faults when importing certs - manual, config?
  • From: Michael Reilly <michaelr@xxxxxxxxx>
  • Date: Thu, 27 Apr 2006 19:42:29 -0700
  • Message-id: <44518115.4020706@xxxxxxxxx>
I am new to SuSE so if the answers to these questions are well known please
point me to the appropriate resource. I have searched but not found anything
relevant (maybe I used the wrong search terms).

I am attempting to configure my laptop running SuSE 10.0 to setup an IPSec
tunnel to my office router (a Cisco) so that I am able to access servers behind
the router. I selected the vpn module in yast and imported my key. Then I
tried to import the CA certificate in pem format. When I double click on the
certificate filename in the dialog box the entire VPN config window goes away.
The yast control center window remains. I ran the ipsec module from the command
line and this is what I see when the windows disappears -

Host:/etc/ipsec/certificates # /sbin/yast2 ipsec
Segmentation fault at ipsec/complex.ycp:509
/sbin/yast2: line 209: 22020 Segmentation fault $ybindir/y2base $module "$@
" qt -geometry "$Y2_GEOMETRY" $Y2QT_ARGS

Is this a known problem?

The certificates were provided by our CA - I manually generated a CSR using
openssl and enrolled with our CA. I now have my private key, laptop certificate
and CA certificate all in pem format.

As an alternative is there a HowTo or similar document to allow me to manually
configure openswan to use X.509 certificates and to be able to access the
servers at the office?

Thanks,

michael
--
---- ---- ----
Michael Reilly michaelr@xxxxxxxxx
Cisco Systems, California

< Previous Next >
This Thread
  • No further messages