Mailinglist Archive: opensuse-security (232 mails)

< Previous Next >
Re: [suse-security] repeated kernel crash, posibly after last update (dma_timer_expiry)
  • From: Jürgen Mell <juergen.mell@xxxxxxxxxxx>
  • Date: Wed, 05 Oct 2005 08:50:23 +0200
  • Message-id: <434377AF.1050003@xxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Michel Messerschmidt wrote:
> Carlos E. R. said:
>
>>Yesterday evening I had three crashes. Around 10-20 minutes after actively
>>using the computer, it suddenly became very sluggish, the mouse jumped,
>>and finally froze completely, within 15" of the first symptoms: not even
>>num-lock key/led worked. After rebooting, nothing showed in any log.
>>
>>The last time I was fast enough to jump to console-10, and I saw this line
>>appearing (hand copied):
>>
>> kernel: hdb dma_timer_expiry: dma status= 0x64
>>[...]
>>Thinking that it could be the last kernel upgrade, I have reverted to
>>2.6.11.4-21.8, and so far, it is working...
>
>
> I don't think this problem affects only the latest Suse kernel.
> It seems to be a bug common to all "new" IDE driver versions.
>
> I have the same behaviour on my home PC under Debian Sarge (kernel 2.6.8...)
> and Suse 9.0 (kernel 2.4.18...), but only if I switch the harddisks to
> MWDMA. With UltraDMA, the error frequency is higher, but after some time
> the driver disables DMA completly and resets the IDE bus thus avoiding the
> crash.
> Until now, I had no problems with disabled DMA (but that is not an option
> for a multimedia PC with video editing/playback).
>
> Some more observations:
> I have 3 IDE harddisks, but only the newer ones (Samsung 120GB, ATA7 and
> Seagate 160GB, ATA6) are effected by these DMA timeeout errors. The older
> drive (IBM 30GB, ATA5) runs without problem.
> Changing all IDE cables made no differences.
> I tried nearly all possible drive connections (IDE bus 0/1, master/slave),
> but the errors always effect the same drives (with no noticeable change
> in the error rate).

The same here: SUSE kernel 2.6.13-9-default, disk IBM IC35, controller
VIA vt8233a

Jürgen


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFDQ3ettMrl3JEeRvwRAqT5AJ4//agiphAj3+XvwN3pdGbTUtEFbgCfZQp2
EvPv1LqMOoLGDt2IZe2sMe0=
=IfFS
-----END PGP SIGNATURE-----

< Previous Next >
Follow Ups