Mailinglist Archive: opensuse-security (228 mails)

< Previous Next >
Re: [suse-security] Linux and forkbomb - with link
  • From: Marcus Meissner <meissner@xxxxxxx>
  • Date: Sat, 19 Mar 2005 16:13:44 +0100
  • Message-id: <20050319151344.GF4503@xxxxxxx>
On Fri, Mar 18, 2005 at 12:47:51PM -0600, Jim Flanagan wrote:
> Sorry, my earlier post did not include the link to the story at
> securityfocus.com
>
> Are any of the currently supported Suse versions suseptable to this
> forkbomb attack? I'm not very sure what it is, but I'm sure many of you
> are. I'm running suse 8.2 pro and 9.1 pro.

Yes it is.

Because we have unlimited ulimits by default.

To fix that:
Install the "ulimit" package.
Adapt /etc/sysconfig/ulimit to your needs.

Done.

Ciao, Marcus
< Previous Next >
Follow Ups
References