Mailinglist Archive: opensuse-security (145 mails)

< Previous Next >
Re: [suse-security] spamassassin
  • From: Philippe Vogel <filiaap@xxxxxxxxxx>
  • Date: Fri, 19 Nov 2004 22:42:26 +0100
  • Message-id: <419E68C2.8070309@xxxxxxxxxx>
Sandro Trinkler schrieb:


Stefan

The SuSE spamassassin and the CPAN spamassassin are not in the same directory

SuSE -> /usr/bin/spamassassin
CPAN -> /usr/sbin/spamassassin

My workaround was do link the SuSE to the CPAN spamassassin.

To check the correct version:
# spamassassin -V


rgds
Sandro

At 11:12 19.11.2004, Stefan Suurmeijer wrote:

Hi list,

I guess mail security is security too. I just upgraded to SuSE 9.2 (looks fine btw), had everything running until I upgraded spamassassin through CPAN. Now I get the following, very annoying and not very informative error:

ERROR! spamassassin script is v3.000000, but using modules v3.000001!

Can anyone give me a hint as to what might be causing this?

So: SuSE 9.2, with the latest spamassassin release

TIA
Stefan

The SuSE spamassassin and cpan are different. Try to downgrade if possible.
There is the pearl module and the razor agents, spamd and whatevery you decide to add to spamassassin.
Spamd ist the daemon running in background. If you use amavisd-new you got a further program.

I would decide to downgrade and use postfix/amavisd-new + spamd, spamassassin + perlmodules & razor agents.
This runs fine. Otherwise you have much to do to compile and configure it if you do this by hand.

Philippe

< Previous Next >
Follow Ups