Mailinglist Archive: opensuse-security (220 mails)

< Previous Next >
Transition problem from Firewall->Firewall2
Hi all,

I was using SuSE7.2 untill recently when I changed my Hard Drive
and I installed 8.1.
This PC is a Samba/Gateway machine for 3 others (running Win9X).
The problem is that although I kept all the ports and parameters that
the old firwall used to run and retyped them in the new SuSEFirewall2
edition, the direct masquerading that used to work, doesn't any more.
I have made sure that I have configured the Network Card with
enabling the IP Forwarding.
When I enter them and enable the firewall (rcSuSEfireall2 start
at prompt) all looks to work including Samba and DHCP.
However when I type wvdial to enter the internet, wvdial replies
with something like DNS not working and , cannot resolve DNS etc (
my apologies I am not at the machine right now).

Can someone please give me a hand with this? The installation
of SuSE8.1 is out of the box.

Thanx friends.
Chris

# Firewall for Ltrk_Office Srv.
FW_DEV_WORLD="ppp0"
FW_DEV_INT="eth0"
FW_ROUTE="yes"
FW_MASQUERADE="yes"
FW_MASQ_NETS="192.168.10.0/8 127.0.0.0/8"
FW_MASQ_DEV="$FW_DEV_WORLD"
FW_PROTECT_FROM_INTERNAL="yes"
FW_AUTOPROTECT_GLOBAL_SERVICES="yes"
FW_SERVICES_EXTERNAL_TCP="smtp 22 110 123 6257 6699"
FW_SERVICES_EXTERNAL_UDP="smtp domain 22 123 6257 6699"
FW_SERVICES_INTERNAL_TCP="ssh domain smtp 20 22 23 25 67 68 110 123 137 138 139 80 www 901 1024:65535"
FW_SERVICES_INTERNAL_UDP="domain syslog 67 68 80 123 137 138 901 www 1024:65535"
FW_ALLOW_INCOMING_HIGHPORTS_TCP="yes"
FW_ALLOW_INCOMING_HIGHPORTS_UDP="yes"
FW_SERVICE_DNS="no"
FW_SERVICE_DHCLIENT="no"
FW_SERVICE_DHCPD="no"
FW_SERVICE_SAMBA="no"
FW_LOG_DENY_CRIT="yes"
FW_LOG_DENY_ALL="no"
FW_LOG_ACCEPT_CRIT="yes"
FW_LOG_ACCEPT_ALL="no"
FW_KERNEL_SECURITY="yes"
FW_STOP_KEEP_ROUTING_STATE="no"
FW_ALLOW_PING_FW="yes"
FW_ALLOW_PING_DMZ="yes"
##
# END of firewall.rc.config
##
< Previous Next >