Mailinglist Archive: opensuse-security (375 mails)

< Previous Next >
Re: [suse-security] Update SuSE 7.0
On Tue, Sep 24, 2002 at 05:26:28PM +0200, Patrick Schneider wrote:
> > I don't hope it is OT, but is there quick way to update a Pc
> > with the SuSE 7.0 distro installed? We have found a Pc with
> > this distro, but it lacks lots off patches. Yast2 does not
> > have the on-line update option, so is the only option (except
> > upgrading to 7.3/8.0 ) to manually update all relevant rpm's?
>
> Sorry, U can't even use fou4s (fou4s.gaugusch.at), because SuSE has
> removed the update descriptions for 6.4 and 7.0.

and thats where my patch description generator comes in ...

parses recursive directory listings on the ftp server (actually I use
rsync for the listing, since it is way easier to parse), and creates
patch descriptions for found packages with newer versions.

It cannot provide information about /what/ this update fixes, but it
tells you "there is a newer release in the update/* tree than I have
installed". after that, fou4s (or amorsu or yast online update or
whatever) can use these descriptions.

so you don't have to do it all by hand.
as long as there *are* newer versions in that tree, it works.

markus is going to include that in the next release of fou4s
and it IS included in the curren beta 0.7.5, which is available at

http://fou4s.gaugusch.at/beta/

and is named gpd.sh
execute it, and it should work...
but I do not know whether there are actually updates available for the
recent security issues for SuSE 7.0, so you should probably upgrade
anyways...

cheers,
Lars-Gunnar

< Previous Next >