Mailinglist Archive: opensuse-security (499 mails)

< Previous Next >
Kaspersky AntiVirus Trouble
  • From: "sc@xxxxxxxxxx" <sc@xxxxxxxxxx>
  • Date: Tue, 4 Jun 2002 14:38:48 +0200
  • Message-id: <200206041238.g54CcQd17675@xxxxxxxxxxxxxxxxxxxx>
hi all,

i am trying to install Kaspersky AV Linux, but having serious trouble
while compiling the monitor (better "klmon" module - for on access scans)

i folled the handbook-instructions (just a few) but this ends
up in more than 40 lines of errors....at the end of this mail,
www.kaspersky.com, google + groups doesn't helped so far...

any kind of help is welcome - thank you Andreas

(Rainer, could you help again ?)

--------------------------------------------------------------------------------------------------------------

comp1:/opt/AVP/kavmonitor/module.linux # make

gcc -c -D__KERNEL__ -I/usr/src/linux/include -Wall -O2 -fomit-frame-pointer
-fno-strict-aliasing -pipe -fno-strength-reduce -m486 -malign-loops=2
-malign-jumps=2 -malign-functions=2 -DCPU=686 -DMODULE handle_execve.c

In file included from module.h:8,
from handle_execve.c:6:
/usr/include/linux/version.h:2: #error
"======================================================="
/usr/include/linux/version.h:3: #error "You should not
include/usr/include/{linux,asm}/ header"
/usr/include/linux/version.h:4: #error "files directly for the compilation of
kernel modules."
/usr/include/linux/version.h:5: #error ""
/usr/include/linux/version.h:6: #error "glibc now uses kernel header files
from a well-defined"
/usr/include/linux/version.h:7: #error "working kernel version (as
recommended by Linus Torvalds)"
/usr/include/linux/version.h:8: #error "These files are glibc internal and
may not match the"
/usr/include/linux/version.h:9: #error "currently running kernel. They should
only be"
/usr/include/linux/version.h:10: #error "included via other system header
files - user space"
/usr/include/linux/version.h:11: #error "programs should not directly include
<linux/*.h> or"
/usr/include/linux/version.h:12: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13: #error ""
/usr/include/linux/version.h:14: #error "To build kernel modules please do
the following:"
/usr/include/linux/version.h:15: #error ""
/usr/include/linux/version.h:16: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17: #error ""
/usr/include/linux/version.h:18: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19: #error " /lib/modules/`uname -r`/build
exists and points to"
/usr/include/linux/version.h:20: #error " the matching kernel source
directory"
/usr/include/linux/version.h:21: #error ""
/usr/include/linux/version.h:22: #error " o Now copy /boot/vmlinuz.version.h
to"
/usr/include/linux/version.h:23: #error " /lib/modules/`uname
-r`/build/include/linux/version.h"
/usr/include/linux/version.h:24: #error ""
/usr/include/linux/version.h:25: #error " o When compiling, make sure to use
the following"
/usr/include/linux/version.h:26: #error " compiler option to use the
correct include files:"
/usr/include/linux/version.h:27: #error ""
/usr/include/linux/version.h:28: #error " -I/lib/modules/`uname
-r`/build/include"
/usr/include/linux/version.h:29: #error ""
/usr/include/linux/version.h:30: #error " instead of"
/usr/include/linux/version.h:31: #error ""
/usr/include/linux/version.h:32: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33: #error ""
/usr/include/linux/version.h:34: #error " Please adjust the Makefile
accordingly."
/usr/include/linux/version.h:35: #error
"======================================================="

< Previous Next >