Mailinglist Archive: opensuse-security (685 mails)

< Previous Next >
rpm -Fhv und Apache in Suse 7.0
  • From: hexadezimal@xxxxxxx
  • Date: Sun, 3 Mar 2002 02:23:25 +0100 (MET)
  • Message-id: <12206.1015118605@xxxxxxxxxxxx>
Hallo!
Ich habe Suse 7.0, Orignal mit Apache httpd Version 1.3.12 (1.3.12 ist noch
am Laufen)
Gemaess der Security Seite:
http://www.suse.de/de/support/download/updates/70_i386.html
(Abschnitt 26. - 28. April 2001) soll man Apache (auf 1.3.19) upgraden, und
auch die Apache-Module upgraden.
Ich hab die Apache- und Modul-rpms vom Suse-ftp-Server runtergeladen und rpm
-Fhv gemacht, den Apache aber noch nicht neu gestartet, und auch das
httpd.conf noch nicht neu editiert.
Wie man unten am output sieht, hat rpm zwar apache, mod_perl, mod_dav, aber
nicht jserv upgegradet.
FRAGE: Kann ich nun den Apache httpd (wenn ich dann das httpd.conf.rpmnew
editiert und in httpd.conf umbenannt habe) trotzdem neustarten? (Auch ohne dass
mod_jserv upgegradet ist?)
Wie kann ich (in /etc/rc.d/apache ?) den jserv vom Starten abhalten?
Ist das ueberhaupt moeglich ohne Probleme zu machen?

Viele Gruesse

Benno


Hier mein Output:
rpm -Fhv apache.rpm
warning: /etc/httpd/httpd.conf created as /etc/httpd/httpd.conf.rpmnew
apache ##########
Updating etc/rc.config... Done.
rpm -Fhv mod_perl.rpm
mod_perl ##########
rpm -Fhv mod_dav.rpm
mod_dav ##########
rpm -Fhv jserv.rpm
Fehler: fehlgeschlagene Paket-Abhängigkeiten:
apache = 1.3.19-33 wird von jserv-1.1.2-123 gebraucht
java wird von jserv-1.1.2-123 gebraucht

Mit java.rpm vom 18. Juni 01: (Java 1.1.8)
rpm -Fhv java.rpm
no packages require freshening


Hier der relevante Ausschnitt aus
http://www.suse.de/de/support/download/updates/70_i386.html

28 Apr 2001 jserv 1.1.2
Update-Paket fuer Apache
1.3.19
--------------------------------------------------------------------------------
28 Apr 2001 mod_dav 1.0.0
Update-Paket fuer Apache
1.3.19
--------------------------------------------------------------------------------
28 Apr 2001 mod_perl 1.24
Update-Paket fuer Apache
1.3.19
--------------------------------------------------------------------------------
28 Apr 2001 modcontr 1.0.7
Update-Paket fuer Apache
1.3.19
--------------------------------------------------------------------------------
26 Apr 2001 apache 1.3.19

--
GMX - Die Kommunikationsplattform im Internet.
http://www.gmx.net


< Previous Next >
This Thread
  • No further messages