Mailinglist Archive: opensuse-security (757 mails)

< Previous Next >
OPENSSH trouble
  • From: Ruben Safir <ruben@xxxxxxxxxxxx>
  • Date: Fri, 25 Jan 2002 16:12:59 -0500
  • Message-id: <20020125161259.A4408@xxxxxxxxxxxxxxxxx>
Hello

I was hoping someone could guild me on this matter.

I tried to update ssh on 7.0 through yast and to blew apart
my working configuration and I need to fix it.


I have two machines that need to work together througfh ssh and rsync

It needs to authenticate without the password being transfered.

It seems to ignor any changes I make in the system config files.

When I run it I get:

OpenSSH_2.9.9p2, SSH protocols 1.5/2.0, OpenSSL 0x0090581f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Seeding random number generator
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug1: restore_uid
debug1: ssh_connect: getuid 0 geteuid 0 anon 1
debug1: Connecting to muriel.tmm.net [208.0.204.10] port 22.
debug1: temporarily_use_uid: 0/0 (e=0)
debug1: restore_uid
debug1: temporarily_use_uid: 0/0 (e=0)
debug1: restore_uid
debug1: Connection established.
debug1: read PEM private key done: type DSA
debug1: identity file /root/.ssh/identity type 0
debug1: identity file /root/.ssh/id_rsa type 0
debug1: identity file /root/.ssh/id_dsa type -1
debug1: Remote protocol version 1.99, remote software version OpenSSH_2.3.0p1
debug1: match: OpenSSH_2.3.0p1 pat ^OpenSSH_2\.3\.0
Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_2.9.9p2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client 3des-cbc hmac-md5 none
debug1: kex: client->server 3des-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST_OLD sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: dh_gen_key: priv key bits set: 203/384
debug1: bits set: 516/1024
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'muriel.tmm.net' is known and matches the DSA host key.
debug1: Found key in /root/.ssh/known_hosts:7
debug1: bits set: 515/1024
debug1: ssh_dss_verify: signature correct
debug1: kex_derive_keys
debug1: newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: waiting for SSH2_MSG_NEWKEYS
debug1: newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: done: ssh_kex2.
debug1: send SSH2_MSG_SERVICE_REQUEST
debug1: service_accept: ssh-userauth
debug1: got SSH2_MSG_SERVICE_ACCEPT
debug1: authentications that can continue: publickey,password
debug1: next auth method to try is publickey
debug1: try privkey: /root/.ssh/id_rsa
debug1: try privkey: /root/.ssh/id_dsa
debug1: next auth method to try is password


And then the password prompt


I created the public and private keys as follows:
ssh-keygen -b 1024 -N '' -C 'user@xxxxxxxxx' -f ~/.ssh/identity

on the client machine is have id_rsa and identity and id_dsa

On the server I have put the client key under
~/.ssh/authorized_keys

Any help would be apreciated


Ruben



--
__________________________

Brooklyn Linux Solutions
__________________________
http://www.mrbrklyn.com - Consulting
http://www.brooklynonline.com - For the love of Brooklyn
http://www.nylxs.com - Leadership Development in Free Software
http://www.nyfairuse.org - The foundation of Democracy
http://www2.mrbrklyn.com/resources - Unpublished Archive or stories and articles from around the net
http://www2.mrbrklyn.com/mp3/hooked.mp3 - Spring is coming....
http://www2.mrbrklyn.com/downtown.html - See the New Downtown Brooklyn....

1-718-382-5752




< Previous Next >
This Thread
Follow Ups
References