Mailinglist Archive: opensuse-security (465 mails)

< Previous Next >
Problems with OpenSSH after upgrading: private keys broken !
  • From: JW <jw@xxxxxxxxxxxxxxxxxx>
  • Date: Thu, 06 Dec 2001 11:31:42 -0600
  • Message-id: <5.1.0.14.0.20011206112050.03ee1d60@xxxxxxxxxxxxxxxxxxxxxxx>
Hello,

Last night I installed the OpenSSH update from YOU, and this morning I found that all our public keys don't work anymore.

What's worse, generating new ones doesn't work either.

Several of our users have been using RSA keys for months now with no problem at all, we use them for backup jobs and other things where passwords would cause a problem.

We tried generating new RSA keys, that help .
We also tried generating new DSA keys, that didn't help either.

Has anyone else had this problem?

Info for the box in question:

Linux fluorite 2.4.0-64GB-SMP #1 SMP Wed Jan 24 15:52:30 GMT 2001 i686 unknown
SuSE Linux 7.1 (i386)
VERSION = 7.1

Please note I did not download and update the box by hand, I used YOU.

If anyone could provide me with a work-around that doesn't require entering any sort of pass phrase (remember, programs that's can't type passwords need it, not humans) I'd really appreciate it.

Additionally, I'd like to know what caused the problem to begin with - I'm pretty surprised the upgrade broke they keys, I would think that would cause serious problems for a lot of people.

----------------------------------------------------
Jonathan Wilson
System Administrator

Cedar Creek Software http://www.cedarcreeksoftware.com
Central Texas IT http://www.centraltexasit.com


< Previous Next >