Mailinglist Archive: opensuse-security (520 mails)

< Previous Next >
Re: [suse-security] sendmail smtp after pop and Berkely DB
  • From: RoMaN SoFt / LLFB!! <roman@xxxxxxxxxx>
  • Date: Fri, 01 Dec 2000 23:40:46 +0100
  • Message-id: <m0ag2tc03ougao6ie8rle38nh035g4htu4@xxxxxxx>
On Fri, 01 Dec 2000 20:11:58 +0100, you wrote:

>/etc/mail/access-times.db: Berkeley DB 2.X Hash/Little Endian (Version
>5)
>/etc/mail/access.db: Berkeley DB 1.85 Hash/Little Endian (Version
>2...
>---
>the file /etc/mail/access-times.db comes from the relayer packet
>and uses Perl, which uses the newer version of Berkeley DB.
>Sendmails /etc/mail/access.db still uses the old 1.85 library.
>
>I've reinstalled berkdb2.rpm and sendmail.rpm with no effect.
>How can I tell sendmail to use the correct version of the Berkely DB
>libraries ?
>Do I have to recompile it, or are there other possibilities ?

Hi. I downloaded & installed latest Sendmail recently. After
compiling sendmail, I realized something with db's were not good. The
reason: I forgot to compile "makemap" source with comes with the
sendmail tarball. If you use the old makemap bin you'll have problems.
You have to compile new makemap and copy it to the appropiate bin
directories.

Hope it helps...

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
** RoMaN SoFt / LLFB **
roman@xxxxxxxxxx
http://pagina.de/romansoft
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

< Previous Next >
References