Mailinglist Archive: opensuse-security (601 mails)

< Previous Next >
Problems with YaST+sendmail
  • From: Christian Mudra <c_mudra@xxxxxxxxxxxxxxxxxxxx>
  • Date: Fri, 4 Aug 2000 11:23:09 +0200
  • Message-id: <20000804112309.A5692@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
Hi,

I experienced problems with YaST and sendmail. Every time I use YaST
to change the installation (Choose/Install packages), change something
and leave this submenu back to the main menu, a new sendmail.cf
is written. When I change something else with YaST, e.g. System
administration, a warning is written, that sendmail.cf was edited by hand,
and _my_ sendmail.cf is not overwritten.

Here in our installation it is needed not to use the MX-record for smtp,
for which I don't see a way to make that known to YaST.

Also another behaviour:
Using an adapted /etc/mail/linux.mc for creating a sendmail.cf file
I added a
define(`SMTP_MAILER_FLAGS', `0')
to /etc/mail/linux.mc. Compiling with m4, this line is not taken care of,
I get exactly the same result with and without that define.
Both with Solaris 2.5/2.7 it works and adds the 0 to the mailer flags.
(e.g. Msmtp, P=[IPC], F=mDFMuX0, S=11/31, R=21, E=\r\n, L=990, ..)
^

It's annoying to re-install a working sendmail.cf each time I use YaST,
especially as there a several linux machines in our workgroup running.

Any ideas to prevent/fix these behaviours?

Greetings,
Christian.

PS: I'm using YaST 1.05.2 on SuSE 6.4.

----------------------------------------------------------------------------
Christian Mudra Just remember what your mother always told you:
mudra@xxxxxxxxxxxxxxxxxxxx "When you open windows you let in bugs".
AG Wiehagen, Universit├Ąt Kaiserslautern


< Previous Next >
This Thread
  • No further messages