Mailinglist Archive: opensuse-security (601 mails)

< Previous Next >
Problem compiling qmail/portsentry under SuSE 6.4
  • From: jan <jmeyer@xxxxxxxxxxxxx>
  • Date: Fri, 11 Aug 2000 17:55:25 +0200
  • Message-id: <399421ED.310A3772@xxxxxxxxxxxxx>
Hi list,

maybe a little off topic?

but I have problems compiling qmail under SuSE 6.4,
the command "setup check" brings the following output:

--------------------------------------------------------------------------
( cat warn-auto.sh; \
echo CC=\'`head -1 conf-cc`\'; \
echo LD=\'`head -1 conf-ld`\' \
) > auto-ccld.sh
cat auto-ccld.sh make-load.sh > make-load
chmod 755 make-load
cat auto-ccld.sh find-systype.sh > find-systype
chmod 755 find-systype
./find-systype > systype
( cat warn-auto.sh; ./make-load "`cat systype`" ) > load
chmod 755 load
cat auto-ccld.sh make-compile.sh > make-compile
chmod 755 make-compile
( cat warn-auto.sh; ./make-compile "`cat systype`" ) > \
compile
chmod 755 compile
( ( ./compile tryvfork.c && ./load tryvfork ) >/dev/null \
2>&1 \
&& cat fork.h2 || cat fork.h1 ) > fork.h
rm -f tryvfork.o tryvfork
./compile qmail-local.c
qmail-local.c: In function `main':
qmail-local.c:448: warning: return type of `main' is not `int'
./compile qmail.c
./compile quote.c
./compile now.c
./compile gfrom.c
./compile myctime.c
./compile slurpclose.c
cat auto-ccld.sh make-makelib.sh > make-makelib
chmod 755 make-makelib
( cat warn-auto.sh; ./make-makelib "`cat systype`" ) > \
makelib
chmod 755 makelib
./compile case_diffb.c
./compile case_diffs.c
./compile case_lowerb.c
./compile case_lowers.c
./compile case_starts.c
./makelib case.a case_diffb.o case_diffs.o case_lowerb.o \
case_lowers.o case_starts.o
./compile getln.c
./compile getln2.c
./makelib getln.a getln.o getln2.o
./compile subgetopt.c
./compile sgetopt.c
./makelib getopt.a subgetopt.o sgetopt.o
./compile sig_alarm.c
In file included from /usr/include/signal.h:300,
from sig_alarm.c:1:
/usr/include/bits/sigcontext.h:28: asm/sigcontext.h: No such file or
directory
make: *** [sig_alarm.o] Error 1
------------------------------------------------------------------------------

I assume it's due to the SuSE Kernel Includes ?
(I've installed the latest SuSE-Kernel 2.2.14,
which is a modified 2.2.16 as rpm-update from SuSE)

BTW. I get the same error on compiling portsentry

Any help would be appreciated.


jan.meyer

< Previous Next >
Follow Ups