Mailinglist Archive: opensuse-security (260 mails)

< Previous Next >
Re: [suse-security] Help, Having problem with LPD after running harden_suse
Hi2all

Bo, when running harden_suse if you did answered 'Yes' on question 6, that
can cause that problem you have (the same happend here, 'lpr' dont work, and
reinstalling dont solve the problem). The question is: "Do you want strong
permissions on user homedirs, limits and umask?"

Run harden_suse again, answering 'No' in this question 6, and lpr will work
again.
I did got this problem, and this was tested 2/3 times, in two diferent SuSe
6.4 (1 desktop, 1 laptop) allways behaving like this.

Personally i'm using it like this: harden_suse y y y y n n y y n y

[ ]'s bacano

----- Original Message -----
From: Bo Jacobsen
To: Suse securityg group
Sent: Wednesday, July 05, 2000 10:45 AM
Subject: [suse-security] Help, Having problem with LPD after running
harden_suse


After running the script harden_suse, LPD returns the following error:
Unable to print "name of file to print" when ever I print from a win pc
(through Samba) or using the lpr command locally.

I have tried the following without any luck:
1. Running the undo_harden_suse. The script runs without any
complaints, but the error is stil there.
2. Uninstall LPD, reboot and installing LPD again.


As my system is otherwise running without any problems (with or
without harden_suse) I would like to know if anyone has any solution
to this problem, besides reinstalling the whole system.

The printer is a HP IIIP printer connected to an Accton printserver
on the network.
I have used apsfilter/SETUP to first create a remote printer and
thereafter a prefilter that bypasses data to the remote printer.
Everything worked perfectly before I ran harden_suse (I also have a
"clone" linux host on which I have not run suse_harden. On this machine
everything works OK, so it's not just a setup problem).

I can still print to the remote printer created, even through Samba,
but not from any of the Ascii, LP and RAW printers (that are spooled).
If I invoke lpq -Praw it displays the file to be printed in maybe 1 second
and then it's gone so it's actually spooled but just not printed.

I could maybe live with printing through the remote printer if it was not
for the problem that LPD is not spooling print jobs to remote, and the
win clients therefor locks completely while printing.

I'm running Suse Linux 6.4.

Thanks in advance
Bo Jacobsen bjc@xxxxxxxx


< Previous Next >
This Thread
References