Mailinglist Archive: opensuse-security-announce (82 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:1724-1: moderate: Security update for gnutls
openSUSE Security Update: Security update for gnutls
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:1724-1
Rating: moderate
References: #1176086 #1176181 #1176671
Cross-References: CVE-2020-24659
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

This update for gnutls fixes the following issues:

- Fix heap buffer overflow in handshake with no_renegotiation alert sent
(CVE-2020-24659 bsc#1176181)
- FIPS: Implement (EC)DH requirements from SP800-56Arev3 (bsc#1176086)
- FIPS: Use 2048 bit prime in DH selftest (bsc#1176086)
- FIPS: Add TLS KDF selftest (bsc#1176671)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-1724=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

gnutls-3.6.7-lp151.2.21.1
gnutls-debuginfo-3.6.7-lp151.2.21.1
gnutls-debugsource-3.6.7-lp151.2.21.1
gnutls-guile-3.6.7-lp151.2.21.1
gnutls-guile-debuginfo-3.6.7-lp151.2.21.1
libgnutls-dane-devel-3.6.7-lp151.2.21.1
libgnutls-dane0-3.6.7-lp151.2.21.1
libgnutls-dane0-debuginfo-3.6.7-lp151.2.21.1
libgnutls-devel-3.6.7-lp151.2.21.1
libgnutls30-3.6.7-lp151.2.21.1
libgnutls30-debuginfo-3.6.7-lp151.2.21.1
libgnutls30-hmac-3.6.7-lp151.2.21.1
libgnutlsxx-devel-3.6.7-lp151.2.21.1
libgnutlsxx28-3.6.7-lp151.2.21.1
libgnutlsxx28-debuginfo-3.6.7-lp151.2.21.1

- openSUSE Leap 15.1 (x86_64):

libgnutls-devel-32bit-3.6.7-lp151.2.21.1
libgnutls30-32bit-3.6.7-lp151.2.21.1
libgnutls30-32bit-debuginfo-3.6.7-lp151.2.21.1
libgnutls30-hmac-32bit-3.6.7-lp151.2.21.1


References:

https://www.suse.com/security/cve/CVE-2020-24659.html
https://bugzilla.suse.com/1176086
https://bugzilla.suse.com/1176181
https://bugzilla.suse.com/1176671

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages