Mailinglist Archive: opensuse-security-announce (96 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:1326-1: important: Security update for postgresql10
openSUSE Security Update: Security update for postgresql10
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:1326-1
Rating: important
References: #1175193 #1175194
Cross-References: CVE-2020-14349 CVE-2020-14350
Affected Products:
openSUSE Leap 15.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for postgresql10 fixes the following issues:

- update to 10.14:
* CVE-2020-14349, bsc#1175193: Set a secure search_path in logical
replication walsenders and apply workers
* CVE-2020-14350, bsc#1175194: Make contrib modules' installation
scripts more secure.
* https://www.postgresql.org/docs/10/release-10-14.html

This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.2:

zypper in -t patch openSUSE-2020-1326=1



Package List:

- openSUSE Leap 15.2 (i586 x86_64):

postgresql10-10.14-lp152.2.6.2
postgresql10-contrib-10.14-lp152.2.6.2
postgresql10-contrib-debuginfo-10.14-lp152.2.6.2
postgresql10-debuginfo-10.14-lp152.2.6.2
postgresql10-debugsource-10.14-lp152.2.6.2
postgresql10-devel-10.14-lp152.2.6.2
postgresql10-devel-debuginfo-10.14-lp152.2.6.2
postgresql10-plperl-10.14-lp152.2.6.2
postgresql10-plperl-debuginfo-10.14-lp152.2.6.2
postgresql10-plpython-10.14-lp152.2.6.2
postgresql10-plpython-debuginfo-10.14-lp152.2.6.2
postgresql10-pltcl-10.14-lp152.2.6.2
postgresql10-pltcl-debuginfo-10.14-lp152.2.6.2
postgresql10-server-10.14-lp152.2.6.2
postgresql10-server-debuginfo-10.14-lp152.2.6.2
postgresql10-test-10.14-lp152.2.6.2

- openSUSE Leap 15.2 (noarch):

postgresql10-docs-10.14-lp152.2.6.2


References:

https://www.suse.com/security/cve/CVE-2020-14349.html
https://www.suse.com/security/cve/CVE-2020-14350.html
https://bugzilla.suse.com/1175193
https://bugzilla.suse.com/1175194

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages