Mailinglist Archive: opensuse-security-announce (77 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:1169-1: important: Security update for grub2
openSUSE Security Update: Security update for grub2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:1169-1
Rating: important
References: #1168994 #1173812 #1174463 #1174570
Cross-References: CVE-2020-10713 CVE-2020-14308 CVE-2020-14309
CVE-2020-14310 CVE-2020-14311 CVE-2020-15706
CVE-2020-15707
Affected Products:
openSUSE Leap 15.2
______________________________________________________________________________

An update that fixes 7 vulnerabilities is now available.

Description:

This update for grub2 fixes the following issues:

- Fix for CVE-2020-10713 (bsc#1168994)
- Fix for CVE-2020-14308 CVE-2020-14309, CVE-2020-14310, CVE-2020-14311
(bsc#1173812)
- Fix for CVE-2020-15706 (bsc#1174463)
- Fix for CVE-2020-15707 (bsc#1174570)

- Use overflow checking primitives where the arithmetic expression for
buffer
- Use grub_calloc for overflow check and return NULL when it would occur

This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.2:

zypper in -t patch openSUSE-2020-1169=1



Package List:

- openSUSE Leap 15.2 (i586 x86_64):

grub2-2.04-lp152.7.3.4
grub2-branding-upstream-2.04-lp152.7.3.4
grub2-debuginfo-2.04-lp152.7.3.4
grub2-debugsource-2.04-lp152.7.3.4

- openSUSE Leap 15.2 (noarch):

grub2-i386-efi-2.04-lp152.7.3.4
grub2-i386-efi-debug-2.04-lp152.7.3.4
grub2-i386-pc-2.04-lp152.7.3.4
grub2-i386-pc-debug-2.04-lp152.7.3.4
grub2-i386-xen-2.04-lp152.7.3.4
grub2-snapper-plugin-2.04-lp152.7.3.4
grub2-systemd-sleep-plugin-2.04-lp152.7.3.4
grub2-x86_64-efi-2.04-lp152.7.3.4
grub2-x86_64-efi-debug-2.04-lp152.7.3.4
grub2-x86_64-xen-2.04-lp152.7.3.4


References:

https://www.suse.com/security/cve/CVE-2020-10713.html
https://www.suse.com/security/cve/CVE-2020-14308.html
https://www.suse.com/security/cve/CVE-2020-14309.html
https://www.suse.com/security/cve/CVE-2020-14310.html
https://www.suse.com/security/cve/CVE-2020-14311.html
https://www.suse.com/security/cve/CVE-2020-15706.html
https://www.suse.com/security/cve/CVE-2020-15707.html
https://bugzilla.suse.com/1168994
https://bugzilla.suse.com/1173812
https://bugzilla.suse.com/1174463
https://bugzilla.suse.com/1174570

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages