Mailinglist Archive: opensuse-security-announce (91 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:1003-1: moderate: Security update for cairo
openSUSE Security Update: Security update for cairo
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:1003-1
Rating: moderate
References: #1049092
Cross-References: CVE-2017-9814
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for cairo fixes the following issues:

- Fix a memory corruption in pango.
- Revert "Correctly decode Adobe CMYK JPEGs in PDF export".
- Add more FreeeType font color conversions to support COLR/CPAL.
- Fix crash when rendering Microsoft's Segoe UI Emoji Regular font.
- Fix memory leaks found by Coverity.
- Fix assertion failure in the freetype backend. (fdo#105746).
- Add cairo-CVE-2017-9814.patch: Replace malloc with _cairo_malloc and
check cmap size before allocating (bsc#1049092)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-1003=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

cairo-debugsource-1.16.0-lp151.5.3.1
cairo-devel-1.16.0-lp151.5.3.1
cairo-tools-1.16.0-lp151.5.3.1
cairo-tools-debuginfo-1.16.0-lp151.5.3.1
libcairo-gobject2-1.16.0-lp151.5.3.1
libcairo-gobject2-debuginfo-1.16.0-lp151.5.3.1
libcairo-script-interpreter2-1.16.0-lp151.5.3.1
libcairo-script-interpreter2-debuginfo-1.16.0-lp151.5.3.1
libcairo2-1.16.0-lp151.5.3.1
libcairo2-debuginfo-1.16.0-lp151.5.3.1

- openSUSE Leap 15.1 (x86_64):

cairo-devel-32bit-1.16.0-lp151.5.3.1
libcairo-gobject2-32bit-1.16.0-lp151.5.3.1
libcairo-gobject2-32bit-debuginfo-1.16.0-lp151.5.3.1
libcairo-script-interpreter2-32bit-1.16.0-lp151.5.3.1
libcairo-script-interpreter2-32bit-debuginfo-1.16.0-lp151.5.3.1
libcairo2-32bit-1.16.0-lp151.5.3.1
libcairo2-32bit-debuginfo-1.16.0-lp151.5.3.1


References:

https://www.suse.com/security/cve/CVE-2017-9814.html
https://bugzilla.suse.com/1049092

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages