Mailinglist Archive: opensuse-security-announce (73 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:0808-1: moderate: Security update for varnish
openSUSE Security Update: Security update for varnish
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0808-1
Rating: moderate
References: #1169039 #1169040
Cross-References: CVE-2019-20637 CVE-2020-11653
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for varnish fixes the following issues:

- CVE-2019-20637: Fixed an information leak when handling one client
request and the next on the same connection (boo#1169040)
- CVE-2020-11653: Fixed a performance loss due to an assertion failure and
daemon restart when communicating with TLS termination proxy that uses
PROXY version 2 (boo#1169039)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-808=1



Package List:

- openSUSE Leap 15.1 (x86_64):

libvarnishapi2-6.2.1-lp151.3.6.1
libvarnishapi2-debuginfo-6.2.1-lp151.3.6.1
varnish-6.2.1-lp151.3.6.1
varnish-debuginfo-6.2.1-lp151.3.6.1
varnish-debugsource-6.2.1-lp151.3.6.1
varnish-devel-6.2.1-lp151.3.6.1


References:

https://www.suse.com/security/cve/CVE-2019-20637.html
https://www.suse.com/security/cve/CVE-2020-11653.html
https://bugzilla.suse.com/1169039
https://bugzilla.suse.com/1169040

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages