Mailinglist Archive: opensuse-security-announce (69 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:0607-1: moderate: Security update for bouncycastle
openSUSE Security Update: Security update for bouncycastle
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0607-1
Rating: moderate
References: #1072697 #1100694
Cross-References: CVE-2017-13098 CVE-2018-1000613
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for bouncycastle fixes the following issues:

Version update to 1.60:

* CVE-2018-1000613: Use of Externally-ControlledInput to Select Classes or
Code (boo#1100694)

* Release notes: http://www.bouncycastle.org/releasenotes.html

Version update to 1.59:

* CVE-2017-13098: Fix against Bleichenbacher oracle when not using the
lightweight APIs (boo#1072697).
* Release notes: http://www.bouncycastle.org/releasenotes.html


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-607=1



Package List:

- openSUSE Leap 15.1 (noarch):

bouncycastle-1.60-lp151.3.3.1
bouncycastle-javadoc-1.60-lp151.3.3.1


References:

https://www.suse.com/security/cve/CVE-2017-13098.html
https://www.suse.com/security/cve/CVE-2018-1000613.html
https://bugzilla.suse.com/1072697
https://bugzilla.suse.com/1100694

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages