Mailinglist Archive: opensuse-security-announce (55 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:0314-1: moderate: Security update for ovmf
openSUSE Security Update: Security update for ovmf
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0314-1
Rating: moderate
References: #1153072 #1163927 #1163959 #1163969
Cross-References: CVE-2019-14553 CVE-2019-14559 CVE-2019-14563
CVE-2019-14575
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for ovmf fixes the following issues:

Security issues fixed:

- CVE-2019-14563: Fixed a memory corruption caused by insufficient numeric
truncation (bsc#1163959).
- CVE-2019-14553: Fixed the TLS certification verification in
HTTPS-over-IPv6 boot sequences (bsc#1153072).
- CVE-2019-14559: Fixed a remotely exploitable memory leak in the ARP
handling code (bsc#1163927).
- CVE-2019-14575: Fixed an insufficient signature check in the
DxeImageVerificationHandler (bsc#1163969).
- Enabled HTTPS-over-IPv6 (bsc#1153072).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-314=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

ovmf-2017+git1510945757.b2662641d5-lp151.11.3.1
ovmf-tools-2017+git1510945757.b2662641d5-lp151.11.3.1

- openSUSE Leap 15.1 (x86_64):

qemu-ovmf-x86_64-debug-2017+git1510945757.b2662641d5-lp151.11.3.1

- openSUSE Leap 15.1 (noarch):

qemu-ovmf-ia32-2017+git1510945757.b2662641d5-lp151.11.3.1
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.3.1


References:

https://www.suse.com/security/cve/CVE-2019-14553.html
https://www.suse.com/security/cve/CVE-2019-14559.html
https://www.suse.com/security/cve/CVE-2019-14563.html
https://www.suse.com/security/cve/CVE-2019-14575.html
https://bugzilla.suse.com/1153072
https://bugzilla.suse.com/1163927
https://bugzilla.suse.com/1163959
https://bugzilla.suse.com/1163969

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages