Mailinglist Archive: opensuse-security-announce (66 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:0022-1: moderate: Security update for libgcrypt
openSUSE Security Update: Security update for libgcrypt
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0022-1
Rating: moderate
References: #1148987 #1155338 #1155339
Cross-References: CVE-2019-13627
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

This update for libgcrypt fixes the following issues:

Security issues fixed:

- CVE-2019-13627: Mitigation against an ECDSA timing attack (bsc#1148987).

Bug fixes:

- Added CMAC AES self test (bsc#1155339).
- Added CMAC TDES self test missing (bsc#1155338).
- Fix test dsa-rfc6979 in FIPS mode.

This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-22=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libgcrypt-cavs-1.8.2-lp151.9.7.1
libgcrypt-cavs-debuginfo-1.8.2-lp151.9.7.1
libgcrypt-debugsource-1.8.2-lp151.9.7.1
libgcrypt-devel-1.8.2-lp151.9.7.1
libgcrypt-devel-debuginfo-1.8.2-lp151.9.7.1
libgcrypt20-1.8.2-lp151.9.7.1
libgcrypt20-debuginfo-1.8.2-lp151.9.7.1
libgcrypt20-hmac-1.8.2-lp151.9.7.1

- openSUSE Leap 15.1 (x86_64):

libgcrypt-devel-32bit-1.8.2-lp151.9.7.1
libgcrypt-devel-32bit-debuginfo-1.8.2-lp151.9.7.1
libgcrypt20-32bit-1.8.2-lp151.9.7.1
libgcrypt20-32bit-debuginfo-1.8.2-lp151.9.7.1
libgcrypt20-hmac-32bit-1.8.2-lp151.9.7.1


References:

https://www.suse.com/security/cve/CVE-2019-13627.html
https://bugzilla.suse.com/1148987
https://bugzilla.suse.com/1155338
https://bugzilla.suse.com/1155339

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages