Mailinglist Archive: opensuse-security-announce (66 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:0015-1: moderate: Security update for trousers
openSUSE Security Update: Security update for trousers
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0015-1
Rating: moderate
References: #1157651
Cross-References: CVE-2019-18898
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for trousers fixes the following issues:

- CVE-2019-18898: Fixed a local symlink attack where a rogue tss user
could have gain ownership of arbitrary files in the system during
installation/update of the trousers package (bsc#1157651).

This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-15=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libtspi1-0.3.14-lp151.4.3.1
libtspi1-debuginfo-0.3.14-lp151.4.3.1
trousers-0.3.14-lp151.4.3.1
trousers-debuginfo-0.3.14-lp151.4.3.1
trousers-debugsource-0.3.14-lp151.4.3.1
trousers-devel-0.3.14-lp151.4.3.1

- openSUSE Leap 15.1 (x86_64):

libtspi1-32bit-0.3.14-lp151.4.3.1
libtspi1-32bit-debuginfo-0.3.14-lp151.4.3.1


References:

https://www.suse.com/security/cve/CVE-2019-18898.html
https://bugzilla.suse.com/1157651

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages