Mailinglist Archive: opensuse-security-announce (43 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2698-1: moderate: Security update for mariadb
openSUSE Security Update: Security update for mariadb
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2698-1
Rating: moderate
References: #1156669
Cross-References: CVE-2019-2737 CVE-2019-2739 CVE-2019-2740
CVE-2019-2758 CVE-2019-2805 CVE-2019-2938
CVE-2019-2974
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes 7 vulnerabilities is now available.

Description:

This update for mariadb to version 10.2.29 fixes the following issues:

MariaDB was updated to 10.2.29 (bsc#1156669)

Security issues fixed:

- CVE-2019-2737: Fixed an issue where could lead a remote attacker to
cause denial of service
- CVE-2019-2938: Fixed an issue where could lead a remote attacker to
cause denial of service
- CVE-2019-2740: Fixed an issue where could lead a local attacker to cause
denial of service
- CVE-2019-2805: Fixed an issue where could lead a local attacker to cause
denial of service
- CVE-2019-2974: Fixed an issue where could lead a remote attacker to
cause denial of service
- CVE-2019-2758: Fixed an issue where could lead a local attacker to cause
denial of service
or data corruption
- CVE-2019-2739: Fixed an issue where could lead a local attacker to cause
denial of service
or data corruption

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-2698=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libmysqld-devel-10.2.29-lp151.2.9.1
libmysqld19-10.2.29-lp151.2.9.1
libmysqld19-debuginfo-10.2.29-lp151.2.9.1
mariadb-10.2.29-lp151.2.9.1
mariadb-bench-10.2.29-lp151.2.9.1
mariadb-bench-debuginfo-10.2.29-lp151.2.9.1
mariadb-client-10.2.29-lp151.2.9.1
mariadb-client-debuginfo-10.2.29-lp151.2.9.1
mariadb-debuginfo-10.2.29-lp151.2.9.1
mariadb-debugsource-10.2.29-lp151.2.9.1
mariadb-galera-10.2.29-lp151.2.9.1
mariadb-test-10.2.29-lp151.2.9.1
mariadb-test-debuginfo-10.2.29-lp151.2.9.1
mariadb-tools-10.2.29-lp151.2.9.1
mariadb-tools-debuginfo-10.2.29-lp151.2.9.1

- openSUSE Leap 15.1 (noarch):

mariadb-errormessages-10.2.29-lp151.2.9.1


References:

https://www.suse.com/security/cve/CVE-2019-2737.html
https://www.suse.com/security/cve/CVE-2019-2739.html
https://www.suse.com/security/cve/CVE-2019-2740.html
https://www.suse.com/security/cve/CVE-2019-2758.html
https://www.suse.com/security/cve/CVE-2019-2805.html
https://www.suse.com/security/cve/CVE-2019-2938.html
https://www.suse.com/security/cve/CVE-2019-2974.html
https://bugzilla.suse.com/1156669

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages