Mailinglist Archive: opensuse-security-announce (43 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2599-1: moderate: Security update for phpMyAdmin
openSUSE Security Update: Security update for phpMyAdmin
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2599-1
Rating: moderate
References: #1157614
Cross-References: CVE-2019-18622
Affected Products:
openSUSE Leap 15.1
openSUSE Leap 15.0
openSUSE Backports SLE-15-SP1
openSUSE Backports SLE-15
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for phpMyAdmin fixes the following issues:

phpMyAdmin was updated to 4.9.2:

* CVE-2019-18622: SQL injection in Designer feature (boo#1157614)
* Fixes for "Failed to set session cookie" error
* Advisor with MySQL 8.0.3 and newer
* Fix PHP deprecation errors
* Fix a situation where exporting users after a delete query could remove
users
* Fix incorrect "You do not have privileges to manipulate with the users!"
warning
* Fix copying a database's privileges and several other problems moving
columns with MariaDB
* Fix for phpMyAdmin not selecting all the values when using shift-click
to select during Export


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-2599=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-2599=1

- openSUSE Backports SLE-15-SP1:

zypper in -t patch openSUSE-2019-2599=1

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-2599=1



Package List:

- openSUSE Leap 15.1 (noarch):

phpMyAdmin-4.9.2-lp151.2.9.1

- openSUSE Leap 15.0 (noarch):

phpMyAdmin-4.9.2-lp150.37.1

- openSUSE Backports SLE-15-SP1 (noarch):

phpMyAdmin-4.9.2-bp151.3.9.1

- openSUSE Backports SLE-15 (noarch):

phpMyAdmin-4.9.2-bp150.37.1


References:

https://www.suse.com/security/cve/CVE-2019-18622.html
https://bugzilla.suse.com/1157614

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >