Mailinglist Archive: opensuse-security-announce (79 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2550-1: moderate: Security update for ncurses
openSUSE Security Update: Security update for ncurses
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2550-1
Rating: moderate
References: #1103320 #1154036 #1154037
Cross-References: CVE-2019-17594 CVE-2019-17595
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for ncurses fixes the following issues:

Security issues fixed:

- CVE-2019-17594: Fixed a heap-based buffer over-read in the
_nc_find_entry function (bsc#1154036).
- CVE-2019-17595: Fixed a heap-based buffer over-read in the fmt_entry
function (bsc#1154037).

Non-security issue fixed:

- Removed screen.xterm from terminfo database (bsc#1103320).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-2550=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libncurses5-6.1-lp150.9.1
libncurses5-debuginfo-6.1-lp150.9.1
libncurses6-6.1-lp150.9.1
libncurses6-debuginfo-6.1-lp150.9.1
ncurses-debugsource-6.1-lp150.9.1
ncurses-devel-6.1-lp150.9.1
ncurses-devel-debuginfo-6.1-lp150.9.1
ncurses-utils-6.1-lp150.9.1
ncurses-utils-debuginfo-6.1-lp150.9.1
ncurses5-devel-6.1-lp150.9.1
tack-6.1-lp150.9.1
tack-debuginfo-6.1-lp150.9.1
terminfo-6.1-lp150.9.1
terminfo-base-6.1-lp150.9.1
terminfo-iterm-6.1-lp150.9.1
terminfo-screen-6.1-lp150.9.1

- openSUSE Leap 15.0 (x86_64):

libncurses5-32bit-6.1-lp150.9.1
libncurses5-32bit-debuginfo-6.1-lp150.9.1
libncurses6-32bit-6.1-lp150.9.1
libncurses6-32bit-debuginfo-6.1-lp150.9.1
ncurses-devel-32bit-6.1-lp150.9.1
ncurses-devel-32bit-debuginfo-6.1-lp150.9.1
ncurses5-devel-32bit-6.1-lp150.9.1


References:

https://www.suse.com/security/cve/CVE-2019-17594.html
https://www.suse.com/security/cve/CVE-2019-17595.html
https://bugzilla.suse.com/1103320
https://bugzilla.suse.com/1154036
https://bugzilla.suse.com/1154037

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages