Mailinglist Archive: opensuse-security-announce (79 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2514-1: moderate: Security update for libtomcrypt
openSUSE Security Update: Security update for libtomcrypt
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2514-1
Rating: moderate
References: #1153433
Cross-References: CVE-2019-17362
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for libtomcrypt fixes the following issue:

CVE-2019-17362: Fixed an improper detection of invalid UTF-8 sequences
that could have led to DoS or information disclosure via crafted
DER-encoded data (bsc#1153433).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-2514=1



Package List:

- openSUSE Leap 15.1 (x86_64):

libtomcrypt-debugsource-1.17-lp151.3.3.1
libtomcrypt-devel-1.17-lp151.3.3.1
libtomcrypt-examples-1.17-lp151.3.3.1
libtomcrypt0-1.17-lp151.3.3.1
libtomcrypt0-debuginfo-1.17-lp151.3.3.1


References:

https://www.suse.com/security/cve/CVE-2019-17362.html
https://bugzilla.suse.com/1153433

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages