Mailinglist Archive: opensuse-security-announce (79 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2510-1: important: Security update for qemu
openSUSE Security Update: Security update for qemu
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2510-1
Rating: important
References: #1079730 #1098403 #1111025 #1117665 #1119991
#1143794 #1144087 #1145379 #1145427 #1145436
#1145774 #1146873 #1149811 #1152506
Cross-References: CVE-2018-12207 CVE-2018-20126 CVE-2019-11135
CVE-2019-12068 CVE-2019-14378 CVE-2019-15890

Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that solves 6 vulnerabilities and has 8 fixes is
now available.

Description:

This update for qemu fixes the following issues:

qemu was updated to v3.1.1.1, a stable, bug-fix-only release, which
includes 2 fixes we already carry, as well as one additional use-
after-free fix in slirp. (CVE-2018-20126 bsc#1119991, CVE-2019-14378
bsc#1143794, and CVE-2019-15890 bsc#1149811 respectively)

Security issues fixed:

- CVE-2019-12068: Fixed potential DOS in lsi scsi controller emulation
(bsc#1146873)
- CVE-2019-11135: Expose taa-no "feature", indicating CPU does not have
the TSX Async Abort vulnerability. (bsc#1152506)
- CVE-2018-12207: Expose pschange-mc-no "feature", indicating CPU does not
have the page size change machine check vulnerability (bsc#1117665)

Other issues fixed:

- Change how this bug gets fixed (bsc#1144087)
- Disable file locking in the Xen PV disk backend to avoid locking issues
with PV domUs during migration. The issues triggered by the locking can
not be properly handled in libxl. The locking introduced in qemu-2.10
was removed again in qemu-4.0. (bsc#1079730, bsc#1098403, bsc#1111025,
bsc#1145427, bsc#1145774)
- Feature support for vfio-ccw dasd ipl (bsc#1145379 jira-SLE-6132)
- Additional hardware instruction support for s390, also update qemu linux
headers to 5.2-rc1 (bsc#1145436 jira-SLE-6237)


This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-2510=1



Package List:

- openSUSE Leap 15.1 (x86_64):

qemu-3.1.1.1-lp151.7.6.1
qemu-arm-3.1.1.1-lp151.7.6.1
qemu-arm-debuginfo-3.1.1.1-lp151.7.6.1
qemu-audio-alsa-3.1.1.1-lp151.7.6.1
qemu-audio-alsa-debuginfo-3.1.1.1-lp151.7.6.1
qemu-audio-oss-3.1.1.1-lp151.7.6.1
qemu-audio-oss-debuginfo-3.1.1.1-lp151.7.6.1
qemu-audio-pa-3.1.1.1-lp151.7.6.1
qemu-audio-pa-debuginfo-3.1.1.1-lp151.7.6.1
qemu-audio-sdl-3.1.1.1-lp151.7.6.1
qemu-audio-sdl-debuginfo-3.1.1.1-lp151.7.6.1
qemu-block-curl-3.1.1.1-lp151.7.6.1
qemu-block-curl-debuginfo-3.1.1.1-lp151.7.6.1
qemu-block-dmg-3.1.1.1-lp151.7.6.1
qemu-block-dmg-debuginfo-3.1.1.1-lp151.7.6.1
qemu-block-gluster-3.1.1.1-lp151.7.6.1
qemu-block-gluster-debuginfo-3.1.1.1-lp151.7.6.1
qemu-block-iscsi-3.1.1.1-lp151.7.6.1
qemu-block-iscsi-debuginfo-3.1.1.1-lp151.7.6.1
qemu-block-nfs-3.1.1.1-lp151.7.6.1
qemu-block-nfs-debuginfo-3.1.1.1-lp151.7.6.1
qemu-block-rbd-3.1.1.1-lp151.7.6.1
qemu-block-rbd-debuginfo-3.1.1.1-lp151.7.6.1
qemu-block-ssh-3.1.1.1-lp151.7.6.1
qemu-block-ssh-debuginfo-3.1.1.1-lp151.7.6.1
qemu-debuginfo-3.1.1.1-lp151.7.6.1
qemu-debugsource-3.1.1.1-lp151.7.6.1
qemu-extra-3.1.1.1-lp151.7.6.1
qemu-extra-debuginfo-3.1.1.1-lp151.7.6.1
qemu-guest-agent-3.1.1.1-lp151.7.6.1
qemu-guest-agent-debuginfo-3.1.1.1-lp151.7.6.1
qemu-ksm-3.1.1.1-lp151.7.6.1
qemu-kvm-3.1.1.1-lp151.7.6.1
qemu-lang-3.1.1.1-lp151.7.6.1
qemu-linux-user-3.1.1.1-lp151.7.6.1
qemu-linux-user-debuginfo-3.1.1.1-lp151.7.6.1
qemu-linux-user-debugsource-3.1.1.1-lp151.7.6.1
qemu-ppc-3.1.1.1-lp151.7.6.1
qemu-ppc-debuginfo-3.1.1.1-lp151.7.6.1
qemu-s390-3.1.1.1-lp151.7.6.1
qemu-s390-debuginfo-3.1.1.1-lp151.7.6.1
qemu-tools-3.1.1.1-lp151.7.6.1
qemu-tools-debuginfo-3.1.1.1-lp151.7.6.1
qemu-ui-curses-3.1.1.1-lp151.7.6.1
qemu-ui-curses-debuginfo-3.1.1.1-lp151.7.6.1
qemu-ui-gtk-3.1.1.1-lp151.7.6.1
qemu-ui-gtk-debuginfo-3.1.1.1-lp151.7.6.1
qemu-ui-sdl-3.1.1.1-lp151.7.6.1
qemu-ui-sdl-debuginfo-3.1.1.1-lp151.7.6.1
qemu-x86-3.1.1.1-lp151.7.6.1
qemu-x86-debuginfo-3.1.1.1-lp151.7.6.1

- openSUSE Leap 15.1 (noarch):

qemu-ipxe-1.0.0+-lp151.7.6.1
qemu-seabios-1.12.0-lp151.7.6.1
qemu-sgabios-8-lp151.7.6.1
qemu-vgabios-1.12.0-lp151.7.6.1


References:

https://www.suse.com/security/cve/CVE-2018-12207.html
https://www.suse.com/security/cve/CVE-2018-20126.html
https://www.suse.com/security/cve/CVE-2019-11135.html
https://www.suse.com/security/cve/CVE-2019-12068.html
https://www.suse.com/security/cve/CVE-2019-14378.html
https://www.suse.com/security/cve/CVE-2019-15890.html
https://bugzilla.suse.com/1079730
https://bugzilla.suse.com/1098403
https://bugzilla.suse.com/1111025
https://bugzilla.suse.com/1117665
https://bugzilla.suse.com/1119991
https://bugzilla.suse.com/1143794
https://bugzilla.suse.com/1144087
https://bugzilla.suse.com/1145379
https://bugzilla.suse.com/1145427
https://bugzilla.suse.com/1145436
https://bugzilla.suse.com/1145774
https://bugzilla.suse.com/1146873
https://bugzilla.suse.com/1149811
https://bugzilla.suse.com/1152506

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages