Mailinglist Archive: opensuse-security-announce (74 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2347-1: moderate: Security update for lighttpd
openSUSE Security Update: Security update for lighttpd
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2347-1
Rating: moderate
References: #1087369 #1111733 #1115016 #1153722
Cross-References: CVE-2018-19052
Affected Products:
openSUSE Leap 15.1
openSUSE Leap 15.0
openSUSE Backports SLE-15-SP1
openSUSE Backports SLE-15
______________________________________________________________________________

An update that solves one vulnerability and has three fixes
is now available.

Description:

This update for lighttpd to version 1.4.54 fixes the following issues:

Security issues fixed:

- CVE-2018-19052: Fixed a path traversal in mod_alias (boo#1115016).
- Changed the default TLS configuration of lighttpd for better security
out-of-the-box (boo#1087369).


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-2347=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-2347=1

- openSUSE Backports SLE-15-SP1:

zypper in -t patch openSUSE-2019-2347=1

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-2347=1



Package List:

- openSUSE Leap 15.1 (x86_64):

lighttpd-1.4.54-lp151.3.3.1
lighttpd-debuginfo-1.4.54-lp151.3.3.1
lighttpd-debugsource-1.4.54-lp151.3.3.1
lighttpd-mod_authn_gssapi-1.4.54-lp151.3.3.1
lighttpd-mod_authn_gssapi-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_authn_ldap-1.4.54-lp151.3.3.1
lighttpd-mod_authn_ldap-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_authn_mysql-1.4.54-lp151.3.3.1
lighttpd-mod_authn_mysql-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_authn_pam-1.4.54-lp151.3.3.1
lighttpd-mod_authn_pam-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_authn_sasl-1.4.54-lp151.3.3.1
lighttpd-mod_authn_sasl-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_cml-1.4.54-lp151.3.3.1
lighttpd-mod_cml-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_geoip-1.4.54-lp151.3.3.1
lighttpd-mod_geoip-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_magnet-1.4.54-lp151.3.3.1
lighttpd-mod_magnet-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_maxminddb-1.4.54-lp151.3.3.1
lighttpd-mod_maxminddb-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_mysql_vhost-1.4.54-lp151.3.3.1
lighttpd-mod_mysql_vhost-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_rrdtool-1.4.54-lp151.3.3.1
lighttpd-mod_rrdtool-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_trigger_b4_dl-1.4.54-lp151.3.3.1
lighttpd-mod_trigger_b4_dl-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_vhostdb_dbi-1.4.54-lp151.3.3.1
lighttpd-mod_vhostdb_dbi-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_vhostdb_ldap-1.4.54-lp151.3.3.1
lighttpd-mod_vhostdb_ldap-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_vhostdb_mysql-1.4.54-lp151.3.3.1
lighttpd-mod_vhostdb_mysql-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_vhostdb_pgsql-1.4.54-lp151.3.3.1
lighttpd-mod_vhostdb_pgsql-debuginfo-1.4.54-lp151.3.3.1
lighttpd-mod_webdav-1.4.54-lp151.3.3.1
lighttpd-mod_webdav-debuginfo-1.4.54-lp151.3.3.1

- openSUSE Leap 15.0 (x86_64):

lighttpd-1.4.54-lp150.2.3.1
lighttpd-debuginfo-1.4.54-lp150.2.3.1
lighttpd-debugsource-1.4.54-lp150.2.3.1
lighttpd-mod_authn_gssapi-1.4.54-lp150.2.3.1
lighttpd-mod_authn_gssapi-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_authn_ldap-1.4.54-lp150.2.3.1
lighttpd-mod_authn_ldap-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_authn_mysql-1.4.54-lp150.2.3.1
lighttpd-mod_authn_mysql-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_authn_pam-1.4.54-lp150.2.3.1
lighttpd-mod_authn_pam-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_authn_sasl-1.4.54-lp150.2.3.1
lighttpd-mod_authn_sasl-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_cml-1.4.54-lp150.2.3.1
lighttpd-mod_cml-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_geoip-1.4.54-lp150.2.3.1
lighttpd-mod_geoip-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_magnet-1.4.54-lp150.2.3.1
lighttpd-mod_magnet-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_maxminddb-1.4.54-lp150.2.3.1
lighttpd-mod_maxminddb-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_mysql_vhost-1.4.54-lp150.2.3.1
lighttpd-mod_mysql_vhost-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_rrdtool-1.4.54-lp150.2.3.1
lighttpd-mod_rrdtool-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_trigger_b4_dl-1.4.54-lp150.2.3.1
lighttpd-mod_trigger_b4_dl-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_vhostdb_dbi-1.4.54-lp150.2.3.1
lighttpd-mod_vhostdb_dbi-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_vhostdb_ldap-1.4.54-lp150.2.3.1
lighttpd-mod_vhostdb_ldap-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_vhostdb_mysql-1.4.54-lp150.2.3.1
lighttpd-mod_vhostdb_mysql-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_vhostdb_pgsql-1.4.54-lp150.2.3.1
lighttpd-mod_vhostdb_pgsql-debuginfo-1.4.54-lp150.2.3.1
lighttpd-mod_webdav-1.4.54-lp150.2.3.1
lighttpd-mod_webdav-debuginfo-1.4.54-lp150.2.3.1

- openSUSE Backports SLE-15-SP1 (aarch64 ppc64le s390x x86_64):

lighttpd-1.4.54-bp151.4.3.1
lighttpd-mod_authn_gssapi-1.4.54-bp151.4.3.1
lighttpd-mod_authn_ldap-1.4.54-bp151.4.3.1
lighttpd-mod_authn_mysql-1.4.54-bp151.4.3.1
lighttpd-mod_authn_pam-1.4.54-bp151.4.3.1
lighttpd-mod_authn_sasl-1.4.54-bp151.4.3.1
lighttpd-mod_cml-1.4.54-bp151.4.3.1
lighttpd-mod_geoip-1.4.54-bp151.4.3.1
lighttpd-mod_magnet-1.4.54-bp151.4.3.1
lighttpd-mod_maxminddb-1.4.54-bp151.4.3.1
lighttpd-mod_mysql_vhost-1.4.54-bp151.4.3.1
lighttpd-mod_rrdtool-1.4.54-bp151.4.3.1
lighttpd-mod_trigger_b4_dl-1.4.54-bp151.4.3.1
lighttpd-mod_vhostdb_dbi-1.4.54-bp151.4.3.1
lighttpd-mod_vhostdb_ldap-1.4.54-bp151.4.3.1
lighttpd-mod_vhostdb_mysql-1.4.54-bp151.4.3.1
lighttpd-mod_vhostdb_pgsql-1.4.54-bp151.4.3.1
lighttpd-mod_webdav-1.4.54-bp151.4.3.1

- openSUSE Backports SLE-15 (aarch64 ppc64le s390x x86_64):

lighttpd-1.4.54-bp150.3.3.1
lighttpd-debuginfo-1.4.54-bp150.3.3.1
lighttpd-debugsource-1.4.54-bp150.3.3.1
lighttpd-mod_authn_gssapi-1.4.54-bp150.3.3.1
lighttpd-mod_authn_gssapi-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_authn_ldap-1.4.54-bp150.3.3.1
lighttpd-mod_authn_ldap-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_authn_mysql-1.4.54-bp150.3.3.1
lighttpd-mod_authn_mysql-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_authn_pam-1.4.54-bp150.3.3.1
lighttpd-mod_authn_pam-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_authn_sasl-1.4.54-bp150.3.3.1
lighttpd-mod_authn_sasl-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_cml-1.4.54-bp150.3.3.1
lighttpd-mod_cml-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_geoip-1.4.54-bp150.3.3.1
lighttpd-mod_geoip-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_magnet-1.4.54-bp150.3.3.1
lighttpd-mod_magnet-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_maxminddb-1.4.54-bp150.3.3.1
lighttpd-mod_maxminddb-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_mysql_vhost-1.4.54-bp150.3.3.1
lighttpd-mod_mysql_vhost-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_rrdtool-1.4.54-bp150.3.3.1
lighttpd-mod_rrdtool-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_trigger_b4_dl-1.4.54-bp150.3.3.1
lighttpd-mod_trigger_b4_dl-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_vhostdb_dbi-1.4.54-bp150.3.3.1
lighttpd-mod_vhostdb_dbi-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_vhostdb_ldap-1.4.54-bp150.3.3.1
lighttpd-mod_vhostdb_ldap-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_vhostdb_mysql-1.4.54-bp150.3.3.1
lighttpd-mod_vhostdb_mysql-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_vhostdb_pgsql-1.4.54-bp150.3.3.1
lighttpd-mod_vhostdb_pgsql-debuginfo-1.4.54-bp150.3.3.1
lighttpd-mod_webdav-1.4.54-bp150.3.3.1
lighttpd-mod_webdav-debuginfo-1.4.54-bp150.3.3.1


References:

https://www.suse.com/security/cve/CVE-2018-19052.html
https://bugzilla.suse.com/1087369
https://bugzilla.suse.com/1111733
https://bugzilla.suse.com/1115016
https://bugzilla.suse.com/1153722

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages